summaryrefslogtreecommitdiffstats
path: root/contrib/dialog/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/dialog/configure.in')
-rw-r--r--contrib/dialog/configure.in44
1 files changed, 34 insertions, 10 deletions
diff --git a/contrib/dialog/configure.in b/contrib/dialog/configure.in
index 2e8630c..75ce244 100644
--- a/contrib/dialog/configure.in
+++ b/contrib/dialog/configure.in
@@ -1,4 +1,4 @@
-dnl $Id: configure.in,v 1.75 2012/12/30 22:38:00 tom Exp $
+dnl $Id: configure.in,v 1.79 2013/09/02 14:02:57 tom Exp $
dnl Process this file with autoconf to produce a configure script.
dnl ---------------------------------------------------------------------------
dnl Copyright 1999-2011,2012 -- Thomas E. Dickey
@@ -44,6 +44,7 @@ AC_PROG_CPP
AC_PROG_MAKE_SET
AC_PROG_RANLIB
AC_PROG_INSTALL
+CF_PROG_LN_S
CF_PROG_LINT
dnl needed for CF_WITH_LIBTOOL
@@ -59,23 +60,36 @@ CF_XOPEN_SOURCE
CF_LARGEFILE
CF_WITH_WARNINGS
+CF_PKG_CONFIG
dnl
dnl Allow dialog program and library to be renamed.
+AC_MSG_CHECKING(for this package's name)
AC_ARG_WITH(package,
[ --with-package=XXX rename dialog to XXX, library to libXXX.a, etc],
[PACKAGE=$withval],
[PACKAGE=dialog])
+AC_MSG_RESULT($PACKAGE)
CF_VERSION_INFO(dialog,$PACKAGE)
+CFG_ROOTNAME=$PACKAGE
+HDR_ROOTNAME=$PACKAGE
+LIB_ROOTNAME=$PACKAGE
+
+AC_SUBST(CFG_ROOTNAME)
+AC_SUBST(HDR_ROOTNAME)
+AC_SUBST(LIB_ROOTNAME)
+
dnl
dnl If package is renamed, it is useful to have the dlg_XXX headers in a
dnl subdirectory (using the package name) so that multiple versions of the
dnl headers can coexist.
+AC_MSG_CHECKING(if we should install dlg_XXX headers to subdirectory)
AC_ARG_ENABLE(header-subdir,
[ --enable-header-subdir install dlg_XXX headers to subdirectory],
[SUB_INC=$enableval],
[SUB_INC=no])
+AC_MSG_RESULT($SUB_INC)
AC_SUBST(SUB_INC)
dnl
@@ -93,17 +107,13 @@ CF_ARG_MSG_ENABLE([if you want --trace option],
[EXTRAOBJS="$EXTRAOBJS trace\$o"
AC_DEFINE(HAVE_DLG_TRACE,1,[Define to 1 to support --trace option])],,yes)
-LIBTOOL_MAKE="#"
-CF_WITH_LIBTOOL
-if test "$with_libtool" = "yes" ; then
- OBJEXT="lo"
- LIBTOOL_MAKE=
- CF_WITH_LIBTOOL_OPTS
-fi
-AC_SUBST(LIBTOOL_MAKE)
+CF_LD_RPATH_OPT
+CF_WITH_SHARED_OR_LIBTOOL(DIALOG,${VERSION_MAJOR}.${VERSION_MINOR},`echo "$VERSION" |sed -e 's/:/./g'`)
CF_WITH_CURSES_DIR
+CF_ENABLE_RPATH
+
use_ncurses=no
AC_ARG_WITH(ncurses,
[ --with-ncurses compile/link with ncurses library],
@@ -252,4 +262,18 @@ AC_TRY_LINK([#include <locale.h>],[setlocale(LC_ALL, "")],[AC_DEFINE(HAVE_SETLOC
CF_DISABLE_RPATH_HACK
-AC_OUTPUT(dialog-config makefile $EXTRA_OUTPUT $SUB_MAKEFILE,,,sort -u)
+CF__DEFINE_SHLIB_VARS
+
+AC_OUTPUT(
+ dialog-config
+ makefile
+ $EXTRA_OUTPUT
+ $SUB_MAKEFILE,[
+CF__ADD_SHLIB_RULES(
+ makefile,
+ $LIB_MODEL,
+ [\${LIB_OBJECT}],
+ [\${LIBS} \${LDFLAGS}])
+],[
+CF__INIT_SHLIB_RULES
+],[sort -u])
OpenPOWER on IntegriCloud