summaryrefslogtreecommitdiffstats
path: root/contrib/binutils/gas/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/binutils/gas/doc/Makefile.am')
-rw-r--r--contrib/binutils/gas/doc/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/contrib/binutils/gas/doc/Makefile.am b/contrib/binutils/gas/doc/Makefile.am
index 60761a4..566038c 100644
--- a/contrib/binutils/gas/doc/Makefile.am
+++ b/contrib/binutils/gas/doc/Makefile.am
@@ -5,6 +5,14 @@ AUTOMAKE_OPTIONS = cygnus
# What version of the manual you want; "all" includes everything
CONFIG=all
+# Options to extract the man page from as.texinfo
+MANCONF = -Dman
+
+TEXI2POD = perl $(top_srcdir)/../etc/texi2pod.pl
+
+POD2MAN = pod2man --center="GNU Development Tools" \
+ --release="binutils-$(VERSION)" --section=1
+
man_MANS = as.1
info_TEXINFOS = as.texinfo gasp.texi
@@ -30,9 +38,13 @@ CPU_DOCS = \
c-m32r.texi \
c-m68hc11.texi \
c-m68k.texi \
+ c-m88k.texi \
c-mips.texi \
+ c-mmix.texi \
c-ns32k.texi \
+ c-pdp11.texi \
c-pj.texi \
+ c-ppc.texi \
c-sh.texi \
c-sparc.texi \
c-tic54x.texi \
@@ -54,3 +66,20 @@ noinst_TEXINFOS = internals.texi
DISTCLEANFILES = asconfig.texi
MAINTAINERCLEANFILES = gasver.texi
+
+# Maintenance
+
+# We need it for the taz target in ../../Makefile.in.
+info: $(MANS)
+
+# Build the man page from the texinfo file
+# The sed command removes the no-adjust Nroff command so that
+# the man output looks standard.
+as.1: $(srcdir)/as.texinfo
+ touch $@
+ -$(TEXI2POD) $(MANCONF) < $(srcdir)/as.texinfo > as.pod
+ -($(POD2MAN) as.pod | \
+ sed -e '/^.if n .na/d' > $@.T$$$$ && \
+ mv -f $@.T$$$$ $@) || \
+ (rm -f $@.T$$$$ && exit 1)
+ rm -f as.pod
OpenPOWER on IntegriCloud