summaryrefslogtreecommitdiffstats
path: root/contrib/binutils/gas/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/binutils/gas/configure.in')
-rw-r--r--contrib/binutils/gas/configure.in391
1 files changed, 137 insertions, 254 deletions
diff --git a/contrib/binutils/gas/configure.in b/contrib/binutils/gas/configure.in
index 81e1209..ebb6202 100644
--- a/contrib/binutils/gas/configure.in
+++ b/contrib/binutils/gas/configure.in
@@ -4,9 +4,16 @@ dnl And be careful when changing it! If you must add tests with square
dnl brackets, be sure changequote invocations surround it.
dnl
dnl
-AC_PREREQ(2.5)dnl v2.5 needed for --bindir et al
-AC_INIT(as.h)dnl
-dnl
+dnl v2.5 needed for --bindir et al
+AC_PREREQ(2.5)
+AC_INIT(as.h)
+
+AC_CANONICAL_SYSTEM
+
+AM_INIT_AUTOMAKE(gas, 2.9.1)
+
+AM_PROG_LIBTOOL
+
user_bfd_gas=
AC_ARG_ENABLE(bfd-assembler,
[ --enable-bfd-assembler use BFD back end for writing object files],
@@ -23,17 +30,6 @@ AC_ARG_ENABLE(targets,
no) enable_targets= ;;
*) enable_targets=$enableval ;;
esac])dnl
-AC_ARG_ENABLE(shared,
-[ --enable-shared build shared BFD library],
-[case "${enableval}" in
- yes) shared=true shared_bfd=true shared_opcodes=true ;;
- no) shared=false ;;
- *bfd*opcodes*) shared=true shared_bfd=true shared_opcodes=true ;;
- *opcodes*bfd*) shared=true shared_bfd=true shared_opcodes=true ;;
- *bfd*) shared=true shared_bfd=true ;;
- *opcodes*) shared=true shared_opcodes=true ;;
- *) shared=false ;;
-esac])dnl
AC_ARG_ENABLE(commonbfdlib,
[ --enable-commonbfdlib build shared BFD/opcodes/libiberty library],
[case "${enableval}" in
@@ -42,13 +38,8 @@ AC_ARG_ENABLE(commonbfdlib,
*) AC_MSG_ERROR([bad value ${enableval} for BFD commonbfdlib option]) ;;
esac])dnl
-# Generate a header file -- gets more post-processing by Makefile later.
-AC_CONFIG_HEADER(conf)
-
-dnl For recursion to work right, this must be an absolute pathname.
-AC_CONFIG_AUX_DIR(`cd $srcdir;pwd`/..)
-AC_CANONICAL_SYSTEM
-AC_ARG_PROGRAM
+# Generate a header file
+AM_CONFIG_HEADER(config.h:config.in)
te_file=generic
@@ -75,9 +66,13 @@ changequote(,)dnl
changequote([,])dnl
# check for architecture variants
+ arch=
+ endian=
case ${cpu} in
+ alpha*) cpu_type=alpha ;;
armeb) cpu_type=arm endian=big ;;
arm*) cpu_type=arm endian=little ;;
+ thumb*) cpu_type=arm endian=little ;;
hppa*) cpu_type=hppa ;;
changequote(,)dnl
i[456]86) cpu_type=i386 ;;
@@ -91,18 +86,25 @@ changequote([,])dnl
powerpcle*) cpu_type=ppc endian=little ;;
powerpc*) cpu_type=ppc endian=big ;;
rs6000*) cpu_type=ppc ;;
- sparc64) cpu_type=sparc want_sparc_v9=true ;;
- sparc*) cpu_type=sparc ;;
+ sparclite*) cpu_type=sparc arch=sparclite ;;
+ sparclet*) cpu_type=sparc arch=sparclet ;;
+ sparc64*) cpu_type=sparc arch=v9-64 ;;
+ sparc*) cpu_type=sparc arch=sparclite ;; # ??? See tc-sparc.c.
+ v850*) cpu_type=v850 ;;
*) cpu_type=${cpu} ;;
esac
if test ${this_target} = $target ; then
target_cpu_type=${cpu_type}
+ if test x${endian} = xbig; then
+ AC_DEFINE(TARGET_BYTES_BIG_ENDIAN, 1)
+ elif test x${endian} = xlittle; then
+ AC_DEFINE(TARGET_BYTES_BIG_ENDIAN, 0)
+ fi
elif test ${target_cpu_type} != ${cpu_type} ; then
continue
fi
- targ=${cpu_type}
generic_target=${cpu_type}-$vendor-$os
dev=no
bfd_gas=no
@@ -110,30 +112,27 @@ changequote([,])dnl
# assign object format
case ${generic_target} in
- a29k-*-coff) fmt=coff targ=ebmon29k ;;
- a29k-amd-udi) fmt=coff targ=ebmon29k ;;
- a29k-amd-ebmon) fmt=coff targ=ebmon29k ;;
- a29k-nyu-sym1) fmt=coff targ=ebmon29k ;;
+ a29k-*-coff) fmt=coff ;;
+ a29k-amd-udi) fmt=coff ;;
+ a29k-amd-ebmon) fmt=coff ;;
+ a29k-nyu-sym1) fmt=coff ;;
a29k-*-vxworks*) fmt=coff ;;
- alpha-*-*vms*) fmt=evax ;;
- alpha-*-netware*) fmt=ecoff ;;
- alpha-*-openbsd*) fmt=ecoff ;;
- alpha-*-osf*) fmt=ecoff ;;
- alpha-*-linuxecoff*) fmt=ecoff ;;
- alpha-*-linux*) fmt=elf em=linux ;;
+ alpha*-*-*vms*) fmt=evax ;;
+ alpha*-*-netware*) fmt=ecoff ;;
+ alpha*-*-openbsd*) fmt=ecoff ;;
+ alpha*-*-osf*) fmt=ecoff ;;
+ alpha*-*-linuxecoff*) fmt=ecoff ;;
+ alpha*-*-linux-gnu*) fmt=elf em=linux ;;
+ alpha*-*-netbsd*) fmt=elf em=nbsd ;;
+ arc-*-elf*) fmt=elf bfd_gas=yes ;;
- arm-*-riscix*) fmt=aout targ=arm-lit em=riscix ;;
- arm-*-aout) fmt=aout
- case "$endian" in
- big) targ=arm-big ;;
- *) targ=arm-lit ;;
- esac
- ;;
- arm-*-coff) fmt=coff ;;
+ arm-*-riscix*) fmt=aout em=riscix ;;
+ arm-*-aout) fmt=aout ;;
+ arm-*-coff | thumb-*-coff) fmt=coff ;;
arm-*-riscix*) fmt=aout ;;
- arm-*-pe) fmt=coff targ=armcoff em=pe ;;
+ arm-*-pe | thumb-*-pe) fmt=coff em=pe ;;
d10v-*-*) fmt=elf bfd_gas=yes ;;
@@ -147,140 +146,122 @@ changequote([,])dnl
h8300-*-coff) fmt=coff ;;
- i386-ibm-aix*) fmt=coff targ=i386coff
- em=i386aix ;;
+ i386-ibm-aix*) fmt=coff em=i386aix ;;
i386-sequent-bsd*) fmt=aout em=dynix bfd_gas=yes ;;
i386-*-bsd*) fmt=aout em=386bsd ;;
i386-*-netbsd0.8) fmt=aout em=386bsd ;;
i386-*-netbsd*) fmt=aout em=nbsd bfd_gas=yes;;
i386-*-openbsd*) fmt=aout em=nbsd bfd_gas=yes;;
i386-*-linux*aout* | i386-*-linuxoldld) fmt=aout em=linux ;;
- i386-*-linux*coff*) fmt=coff em=linux
- targ=i386coff ;;
- i386-*-linux*) fmt=elf em=linux ;;
- i386-*-lynxos*) fmt=coff targ=i386coff
- em=lynx ;;
- i386-*-sysv4* | i386-*-solaris* | i386-*-elf | i386-*-freebsdelf*)
+ i386-*-linux*coff*) fmt=coff em=linux ;;
+ i386-*-linux-gnu*) fmt=elf em=linux ;;
+ i386-*-lynxos*) fmt=coff em=lynx ;;
+ i386-*-sysv4* | i386-*-solaris* | i386-*-elf)
fmt=elf ;;
- i386-*-sco*elf*) fmt=elf targ=sco5 ;;
- i386-*-coff | i386-*-sysv* | i386-*-sco* | i386-*-isc*)
- fmt=coff targ=i386coff ;;
+ i386-*-freebsdelf*) fmt=elf ;;
+ i386-*-freebsd*) fmt=aout em=386bsd ;;
+ i386-*-coff | i386-*-sysv* | i386-*-sco3.2v5*coff | i386-*-isc*)
+ fmt=coff ;;
+ i386-*-sco3.2v5*) fmt=elf
+ if test ${this_target} = $target; then
+ AC_DEFINE(SCO_ELF)
+ fi
+ ;;
+ i386-*-sco3.2*) fmt=coff ;;
i386-*-vsta) fmt=aout ;;
- i386-*-go32) fmt=coff targ=i386coff ;;
- i386-*-rtems*) fmt=coff targ=i386coff ;;
+ i386-*-msdosdjgpp* | i386-*-go32* | i386-go32-rtems*)
+ fmt=coff em=go32;;
+ i386-*-rtems*) fmt=coff ;;
i386-*-gnu*) fmt=elf ;;
i386-*-mach*)
fmt=aout em=mach bfd_gas=yes ;;
i386-*-msdos*) fmt=aout ;;
i386-*-moss*) fmt=elf ;;
- i386-*-pe) fmt=coff targ=i386coff em=pe ;;
- i386-*-cygwin32) fmt=coff targ=i386coff em=pe ;;
- i386-*-*nt) fmt=coff targ=i386coff em=pe ;;
+ i386-*-pe) fmt=coff em=pe ;;
+ i386-*-cygwin32*) fmt=coff em=pe bfd_gas=yes ;;
+ i386-*-mingw32*) fmt=coff em=pe bfd_gas=yes ;;
+ i386-*-*nt*) fmt=coff em=pe ;;
i960-*-bout) fmt=bout ;;
- i960-*-coff) fmt=coff em=ic960 targ=ic960coff ;;
- i960-*-rtems*) fmt=coff em=ic960 targ=ic960coff ;;
+ i960-*-coff) fmt=coff em=ic960 ;;
+ i960-*-rtems*) fmt=coff em=ic960 ;;
i960-*-nindy*) fmt=bout ;;
i960-*-vxworks4*) fmt=bout ;;
i960-*-vxworks5.0) fmt=bout ;;
- i960-*-vxworks5.*) fmt=coff em=ic960 targ=ic960coff ;;
+ i960-*-vxworks5.*) fmt=coff em=ic960 ;;
i960-*-vxworks*) fmt=bout ;;
m32r-*-*) fmt=elf bfd_gas=yes ;;
m68k-*-vxworks* | m68k-ericsson-ose | m68k-*-sunos*)
fmt=aout em=sun3 ;;
- m68k-motorola-sysv*) fmt=coff targ=m68kcoff em=delta ;;
- m68k-bull-sysv3*) fmt=coff targ=m68kcoff em=dpx2 ;;
- m68k-apollo-*) fmt=coff targ=apollo em=apollo ;;
+ m68k-motorola-sysv*) fmt=coff em=delta ;;
+ m68k-bull-sysv3*) fmt=coff em=dpx2 ;;
+ m68k-apollo-*) fmt=coff em=apollo ;;
m68k-*-sysv4*) # must be before -sysv*
fmt=elf em=svr4 ;;
m68k-*-elf*) fmt=elf ;;
m68k-*-coff | m68k-*-sysv* | m68k-*-rtems*)
- fmt=coff targ=m68kcoff ;;
+ fmt=coff ;;
m68k-*-hpux*) fmt=hp300 em=hp300 ;;
m68k-*-linux*aout*) fmt=aout em=linux ;;
- m68k-*-linux*) fmt=elf em=linux ;;
- m68k-*-lynxos*) fmt=coff targ=m68kcoff
- em=lynx ;;
+ m68k-*-linux-gnu*) fmt=elf em=linux ;;
+ m68k-*-lynxos*) fmt=coff em=lynx ;;
m68k-*-netbsd*) fmt=aout em=nbsd bfd_gas=yes ;;
m68k-*-openbsd*) fmt=aout em=nbsd bfd_gas=yes ;;
- m68k-apple-aux*) fmt=coff targ=m68kcoff em=aux ;;
+ m68k-apple-aux*) fmt=coff em=aux ;;
m68k-*-psos*) fmt=elf em=psos;;
- m88k-motorola-sysv3*) fmt=coff targ=m88kcoff em=delt88 ;;
- m88k-*-coff*) fmt=coff targ=m88kcoff ;;
+ m88k-motorola-sysv3*) fmt=coff em=delt88 ;;
+ m88k-*-coff*) fmt=coff ;;
# don't change em like *-*-bsd does
- mips-dec-netbsd*) fmt=elf targ=mips-lit endian=little ;;
- mips-dec-openbsd*) fmt=elf targ=mips-lit endian=little ;;
- mips-dec-bsd*) fmt=aout targ=mips-lit ;;
- mips-sony-bsd*) fmt=ecoff targ=mips-big ;;
+ mips-dec-netbsd*) fmt=elf endian=little ;;
+ mips-dec-openbsd*) fmt=elf endian=little ;;
+ mips-dec-bsd*) fmt=aout ;;
+ mips-sony-bsd*) fmt=ecoff ;;
mips-*-bsd*) AC_MSG_ERROR(Unknown vendor for mips-bsd configuration.) ;;
- mips-*-ultrix*) fmt=ecoff targ=mips-lit endian=little ;;
- mips-*-osf*) fmt=ecoff targ=mips-lit endian=little ;;
- mips-*-ecoff*) fmt=ecoff
- case "$endian" in
- big) targ=mips-big ;;
- *) targ=mips-lit ;;
- esac
- ;;
- mips-*-ecoff*) fmt=ecoff targ=mips-big ;;
- mips-*-irix6*) fmt=elf targ=mips-big ;;
- mips-*-irix5*) fmt=elf targ=mips-big ;;
- mips-*-irix*) fmt=ecoff targ=mips-big ;;
- mips-*-lnews*) fmt=ecoff targ=mips-lit em=lnews ;;
- mips-*-riscos*) fmt=ecoff targ=mips-big ;;
- mips-*-sysv*) fmt=ecoff targ=mips-big ;;
- mips-*-elf* | mips-*-rtems* | mips-*-linux* | mips-*-gnu* | mips-*-openbsd*)
- fmt=elf
- case "$endian" in
- big) targ=mips-big ;;
- *) targ=mips-lit ;;
- esac
- ;;
+ mips-*-ultrix*) fmt=ecoff endian=little ;;
+ mips-*-osf*) fmt=ecoff endian=little ;;
+ mips-*-ecoff*) fmt=ecoff ;;
+ mips-*-ecoff*) fmt=ecoff ;;
+ mips-*-irix6*) fmt=elf ;;
+ mips-*-irix5*) fmt=elf ;;
+ mips-*-irix*) fmt=ecoff ;;
+ mips-*-lnews*) fmt=ecoff em=lnews ;;
+ mips-*-riscos*) fmt=ecoff ;;
+ mips-*-sysv*) fmt=ecoff ;;
+ mips-*-elf* | mips-*-rtems* | mips-*-linux-gnu* | mips-*-gnu* | mips-*-openbsd*)
+ fmt=elf ;;
mn10200-*-*) fmt=elf bfd_gas=yes ;;
mn10300-*-*) fmt=elf bfd_gas=yes ;;
ppc-*-pe | ppc-*-cygwin32 | ppc-*-winnt*)
- fmt=coff em=pe
- case "$endian" in
- big) targ=ppc-big ;;
- *) targ=ppc-lit ;;
- esac
- ;;
+ fmt=coff em=pe ;;
ppc-*-aix*) fmt=coff ;;
ppc-*-beos*) fmt=coff ;;
ppc-*-*bsd* | ppc-*-elf* | ppc-*-eabi* | ppc-*-sysv4*)
- fmt=elf
- case "$endian" in
- big) targ=ppc-big ;;
- *) targ=ppc-lit ;;
- esac
- ;;
- ppc-*-linux*) fmt=elf
+ fmt=elf ;;
+ ppc-*-linux-gnu*) fmt=elf
case "$endian" in
- big) targ=ppc-big ;;
- *) AC_MSG_ERROR(Linux must be configured big endian) ;;
+ big) ;;
+ *) AC_MSG_ERROR(GNU/Linux must be configured big endian) ;;
esac
;;
ppc-*-solaris*) fmt=elf
- case "$endian" in
- big) AC_MSG_ERROR(Solaris must be configured little endian) ;;
- *) targ=ppc-sol ;;
- esac
- ;;
- ppc-*-rtems*)
- fmt=elf
- case "$endian" in
- big) targ=ppc-big ;;
- *) targ=ppc-lit ;;
- esac
+ if test ${this_target} = $target; then
+ AC_DEFINE(TARGET_SOLARIS_COMMENT)
+ fi
+ if test x${endian} = xbig; then
+ AC_MSG_ERROR(Solaris must be configured little endian)
+ fi
;;
+ ppc-*-rtems*) fmt=elf ;;
ppc-*-macos* | ppc-*-mpw*)
fmt=coff em=macos ;;
ppc-*-netware*) fmt=elf em=ppcnw ;;
sh-*-elf*) fmt=elf ;;
sh-*-coff*) fmt=coff ;;
+ sh-*-rtems*) fmt=coff ;;
ns32k-pc532-mach* | ns32k-pc532-ux*) fmt=aout em=pc532mach ;;
ns32k-pc532-netbsd* | ns32k-pc532-lites*) fmt=aout em=nbsd532 ;;
@@ -292,7 +273,7 @@ changequote([,])dnl
fmt=aout em=sparcaout ;;
sparc-*-coff) fmt=coff ;;
sparc-*-linux*aout*) fmt=aout em=linux ;;
- sparc-*-linux*) fmt=elf em=linux ;;
+ sparc-*-linux-gnu*) fmt=elf em=linux ;;
sparc-*-lynxos*) fmt=coff em=lynx ;;
sparc-fujitsu-none) fmt=aout ;;
sparc-*-elf | sparc-*-sysv4* | sparc-*-solaris*)
@@ -300,6 +281,12 @@ changequote([,])dnl
sparc-*-netbsd*) fmt=aout em=nbsd bfd_gas=yes ;;
sparc-*-openbsd*) fmt=aout em=nbsd bfd_gas=yes ;;
+ tic30-*-*aout*) fmt=aout bfd_gas=yes ;;
+ tic30-*-*coff*) fmt=coff bfd_gas=yes ;;
+
+
+ v850-*-*) fmt=elf bfd_gas=yes ;;
+
vax-*-bsd* | vax-*-ultrix*)
fmt=aout ;;
vax-*-vms) fmt=vms ;;
@@ -326,7 +313,7 @@ changequote([,])dnl
esac
case ${cpu_type}-${fmt} in
- alpha-*) bfd_gas=yes ;;
+ alpha*-*) bfd_gas=yes ;;
arm-*) bfd_gas=yes ;;
# not yet
# i386-aout) bfd_gas=preferred ;;
@@ -344,10 +331,16 @@ changequote([,])dnl
# do we need the opcodes library?
case ${cpu_type} in
- vax | i386)
+ vax | i386 | tic30)
;;
*)
need_opcodes=yes
+
+ case "${enable_shared}" in
+ yes) shared_opcodes=true ;;
+ *opcodes*) shared_opcodes=true ;;
+ *) shared_opcodes=false ;;
+ esac
if test "${shared_opcodes}" = "true"; then
# A shared libopcodes must be linked against libbfd.
need_bfd=yes
@@ -355,12 +348,6 @@ changequote([,])dnl
;;
esac
- test -n "$want_sparc_v9" && AC_DEFINE(SPARC_V9)
-
- case ${cpu}-${vendor}-${os} in
- sparc64-*-elf*) AC_DEFINE(SPARC_ARCH64) ;;
- esac
-
case ${cpu_type} in
m32r)
case ${extra_objects} in
@@ -395,6 +382,12 @@ changequote([,])dnl
fi
;;
+ sparc)
+ if test $this_target = $target ; then
+ AC_DEFINE_UNQUOTED(DEFAULT_ARCH, "${arch}")
+ fi
+ ;;
+
*)
;;
esac
@@ -404,7 +397,6 @@ changequote([,])dnl
if test $this_target = $target ; then
primary_bfd_gas=$bfd_gas
obj_format=$fmt
- gas_target=$targ
te_file=$em
if test $bfd_gas = no ; then
@@ -420,7 +412,7 @@ changequote([,])dnl
case ${generic_target}-${fmt} in
mips-*-irix5*-*) emulation="mipsbelf mipslelf mipself mipsbecoff mipslecoff mipsecoff" ;;
- mips-*-linux*-*) case "$endian" in
+ mips-*-linux-gnu*-*) case "$endian" in
big) emulation="mipsbelf mipslelf mipself mipsbecoff mipslecoff mipsecoff" ;;
*) emulation="mipslelf mipsbelf mipself mipslecoff mipsbecoff mipsecoff" ;;
esac ;;
@@ -467,14 +459,6 @@ if test ! -r ${srcdir}/config/obj-${obj_format}.c; then
AC_MSG_ERROR(GAS does not have support for object file format ${obj_format})
fi
-# and target makefile frag
-
-target_frag=${srcdir}/config/${gas_target}.mt
-if test ! -r ${target_frag}; then
- target_frag=/dev/null # ick! but subst_file can't be conditionalized
-fi
-AC_SUBST_FILE(target_frag)
-
case ${user_bfd_gas}-${primary_bfd_gas} in
yes-yes | no-no)
# We didn't override user's choice.
@@ -597,74 +581,18 @@ esac
# do we need the opcodes library?
case "${need_opcodes}" in
yes)
- OPCODES_DEP=../opcodes/libopcodes.a
- OPCODES_LIB='-L../opcodes -lopcodes'
-
- # We need to handle some special cases for shared libraries.
- case "${host}" in
- *-*-sunos*)
- # On SunOS, we must link against the name we are going to install,
- # not -lbfd, since SunOS does not support SONAME.
- if test "${shared_opcodes}" = "true"; then
- OPCODES_LIB='-L../opcodes -l`echo opcodes | sed '"'"'$(program_transform_name)'"'"'`'
- fi
- ;;
- alpha*-*-osf*)
- # On Alpha OSF/1, the native linker searches all the -L
- # directories for any LIB.so files, and only then searches for any
- # LIB.a files. That means that if there is an installed
- # libbfd.so, but this build is not done with --enable-shared, the
- # link will wind up being against the install libbfd.so rather
- # than the newly built libbfd. To avoid this, we must explicitly
- # link against libbfd.a when --enable-shared is not used.
- if test "${shared_opcodes}" != "true"; then
- OPCODES_LIB='../opcodes/libopcodes.a'
- fi
- ;;
- esac
+ OPCODES_LIB=../opcodes/libopcodes.la
;;
esac
case "${need_bfd}" in
yes)
- BFDDEP=../bfd/libbfd.a
- BFDLIB='-L../bfd -lbfd'
+ BFDLIB=../bfd/libbfd.la
ALL_OBJ_DEPS="$ALL_OBJ_DEPS ../bfd/bfd.h"
-
- # We need to handle some special cases for shared libraries
- case "${host}" in
- *-*-sunos*)
- # On SunOS, we must link against the name we are going to install,
- # not -lbfd, since SunOS does not support SONAME.
- if test "${shared_bfd}" = "true"; then
- BFDLIB='-L../bfd -l`echo bfd | sed '"'"'$(program_transform_name)'"'"'`'
- fi
- ;;
- alpha*-*-osf*)
- # On Alpha OSF/1, the native linker searches all the -L
- # directories for any LIB.so files, and only then searches for any
- # LIB.a files. That means that if there is an installed
- # libbfd.so, but this build is not done with --enable-shared, the
- # link will wind up being against the install libbfd.so rather
- # than the newly built libbfd. To avoid this, we must explicitly
- # link against libbfd.a when --enable-shared is not used.
- if test "${shared_bfd}" != "true"; then
- BFDLIB='../bfd/libbfd.a'
- fi
- ;;
- esac
-
- if test "${commonbfdlib}" = "true"; then
- # when a shared libbfd is built with --enable-commonbfdlib,
- # all of libopcodes is available in libbfd.so
- OPCODES_LIB=
- fi
;;
esac
-AC_SUBST(BFDDEP)
AC_SUBST(BFDLIB)
-AC_SUBST(OPCODES_DEP)
AC_SUBST(OPCODES_LIB)
AC_SUBST(ALL_OBJ_DEPS)
@@ -676,7 +604,14 @@ AC_DEFINE_UNQUOTED(TARGET_VENDOR, "${target_vendor}")
AC_DEFINE_UNQUOTED(TARGET_OS, "${target_os}")
AC_PROG_CC
-AC_PROG_INSTALL
+
+AC_PROG_YACC
+AC_PROG_LEX
+AC_DECL_YYTEXT
+
+AM_MAINTAINER_MODE
+AM_CYGWIN32
+AM_EXEEXT
AC_CHECK_HEADERS(string.h stdlib.h memory.h strings.h unistd.h stdarg.h varargs.h errno.h sys/types.h)
@@ -741,58 +676,6 @@ GAS_CHECK_DECL_NEEDED(errno, f, int f, [
#endif
])
-HLDFLAGS=
-HLDENV=
-RPATH_ENVVAR=LD_LIBRARY_PATH
-# If we have shared libraries, try to set rpath reasonably.
-if test "${shared}" = "true"; then
- case "${host}" in
- *-*-hpux*)
- HLDFLAGS='-Wl,+s,+b,$(libdir)'
- RPATH_ENVVAR=SHLIB_PATH
- ;;
- *-*-irix5* | *-*-irix6*)
- HLDFLAGS='-Wl,-rpath,$(libdir)'
- ;;
- *-*-linux*aout*)
- ;;
- *-*-linux*)
- HLDFLAGS='-Wl,-rpath,$(libdir)'
- ;;
- *-*-solaris*)
- HLDFLAGS='-R $(libdir)'
- ;;
- *-*-sysv4*)
- HLDENV='if test -z "$${LD_RUN_PATH}"; then LD_RUN_PATH=$(libdir); else LD_RUN_PATH=$${LD_RUN_PATH}:$(libdir); fi; export LD_RUN_PATH;'
- ;;
- esac
-fi
-
-# On SunOS, if the linker supports the -rpath option, use it to
-# prevent ../bfd and ../opcodes from being included in the run time
-# search path.
-case "${host}" in
- *-*-sunos*)
- echo 'main () { }' > conftest.c
- ${CC} -o conftest -Wl,-rpath= conftest.c >/dev/null 2>conftest.t
- if grep 'unrecognized' conftest.t >/dev/null 2>&1; then
- :
- elif grep 'No such file' conftest.t >/dev/null 2>&1; then
- :
- elif grep 'do not mix' conftest.t >/dev/null 2>&1; then
- :
- elif test "${shared}" = "true"; then
- HLDFLAGS='-Wl,-rpath=$(libdir)'
- else
- HLDFLAGS='-Wl,-rpath='
- fi
- rm -f conftest.t conftest.c conftest
- ;;
-esac
-AC_SUBST(HLDFLAGS)
-AC_SUBST(HLDENV)
-AC_SUBST(RPATH_ENVVAR)
-
dnl This must come last.
dnl We used to make symlinks to files in the source directory, but now
OpenPOWER on IntegriCloud