summaryrefslogtreecommitdiffstats
path: root/contrib/binutils/gas/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/binutils/gas/configure.in')
-rw-r--r--contrib/binutils/gas/configure.in93
1 files changed, 62 insertions, 31 deletions
diff --git a/contrib/binutils/gas/configure.in b/contrib/binutils/gas/configure.in
index 4250cf2..0be9d21 100644
--- a/contrib/binutils/gas/configure.in
+++ b/contrib/binutils/gas/configure.in
@@ -44,7 +44,7 @@ esac])dnl
using_cgen=no
-build_warnings="-W -Wall"
+build_warnings="-W -Wall -Wstrict-prototypes -Wmissing-prototypes"
AC_ARG_ENABLE(build-warnings,
[ --enable-build-warnings Enable build-time compiler warnings if gcc is used],
[case "${enableval}" in
@@ -139,9 +139,13 @@ changequote([,])dnl
mips*) cpu_type=mips endian=big ;;
pjl*) cpu_type=pj endian=little ;;
pj*) cpu_type=pj endian=big ;;
- powerpcle*) cpu_type=ppc endian=little ;;
+ powerpc*le*) cpu_type=ppc endian=little ;;
powerpc*) cpu_type=ppc endian=big ;;
rs6000*) cpu_type=ppc ;;
+ s390x*) cpu_type=s390 arch=s390x ;;
+ s390*) cpu_type=s390 arch=s390 ;;
+ sh*le) cpu_type=sh endian=little ;;
+ sh*) cpu_type=sh endian=big ;;
sparclite*) cpu_type=sparc arch=sparclite ;;
sparclet*) cpu_type=sparc arch=sparclet ;;
sparc64*) cpu_type=sparc arch=v9-64 ;;
@@ -161,6 +165,7 @@ changequote([,])dnl
dev=no
bfd_gas=no
em=generic
+ mips_stabs_elf=
# assign object format
case ${generic_target} in
@@ -189,7 +194,8 @@ changequote([,])dnl
arm-*-linux*aout*) fmt=aout em=linux ;;
arm*-*-linux-gnu* | arm*-*-uclinux*)
fmt=elf em=linux ;;
- arm-*-netbsd*) fmt=aout em=nbsd ;;
+ arm-*-netbsdelf*) fmt=elf em=nbsd ;;
+ arm-*-netbsd* | arm-*-openbsd*) fmt=aout em=nbsd ;;
arm-*-oabi | thumb-*-oabi) fmt=elf ;;
arm-epoc-pe | thumb-epoc-pe) fmt=coff em=epoc-pe ;;
arm-*-wince) fmt=coff em=wince-pe ;;
@@ -230,6 +236,7 @@ changequote([,])dnl
h8300-*-rtems*) fmt=coff ;;
h8300-*-coff) fmt=coff ;;
+ h8300-*-elf) fmt=elf ;;
h8500-*-rtems*) fmt=coff ;;
h8500-*-coff) fmt=coff ;;
@@ -240,8 +247,16 @@ changequote([,])dnl
i386-*-beoself* | i386-*-beos*) fmt=elf bfd_gas=yes ;;
i386-*-bsd*) fmt=aout em=386bsd ;;
i386-*-netbsd0.8) fmt=aout em=386bsd ;;
- i386-*-netbsdelf*) fmt=elf em=nbsd bfd_gas=yes;;
- i386-*-netbsd*) fmt=aout em=nbsd bfd_gas=yes;;
+ i386-*-netbsd*) em=nbsd bfd_gas=yes
+ case ${cpu} in
+ x86_64) fmt=elf ;;
+ *) case ${os} in
+ *elf*) fmt=elf ;;
+ *) fmt=aout ;;
+ esac
+ ;;
+ esac
+ ;;
i386-*-openbsd*) fmt=aout em=nbsd bfd_gas=yes;;
i386-*-linux*aout* | i386-*-linux*oldld) fmt=aout em=linux ;;
i386-*-linux*coff*) fmt=coff em=linux ;;
@@ -297,8 +312,10 @@ changequote([,])dnl
i960-*-elf*) fmt=elf ;;
ia64-*-elf*) fmt=elf ;;
+ ia64-*-aix*) fmt=elf em=ia64aix ;;
ia64-*-linux-gnu*) fmt=elf em=linux ;;
ia64-*-hpux*) fmt=elf em=hpux ;;
+ ia64-*-netbsd*) fmt=elf em=nbsd ;;
m32r-*-*) fmt=elf bfd_gas=yes ;;
@@ -320,7 +337,9 @@ changequote([,])dnl
m68k-*-linux-gnu*) fmt=elf em=linux ;;
m68k-*-gnu*) fmt=elf ;;
m68k-*-lynxos*) fmt=coff em=lynx ;;
- m68k-*-netbsd*) fmt=aout em=nbsd bfd_gas=yes ;;
+ m68k-*-netbsdelf*) fmt=elf em=nbsd bfd_gas=yes ;;
+ m68k-*-netbsdaout* | m68k-*-netbsd*)
+ fmt=aout em=nbsd bfd_gas=yes ;;
m68k-*-openbsd*) fmt=aout em=nbsd bfd_gas=yes ;;
m68k-apple-aux*) fmt=coff em=aux ;;
m68k-*-psos*) fmt=elf em=psos;;
@@ -332,7 +351,6 @@ changequote([,])dnl
mcore-*-pe) fmt=coff em=pe bfd_gas=yes ;;
# don't change em like *-*-bsd does
- mips-dec-netbsd*) fmt=elf endian=little ;;
mips-dec-openbsd*) fmt=elf endian=little ;;
mips-dec-bsd*) fmt=aout endian=little ;;
mips-sony-bsd*) fmt=ecoff ;;
@@ -346,22 +364,17 @@ changequote([,])dnl
mips-*-irix*) fmt=ecoff ;;
mips-*-lnews*) fmt=ecoff em=lnews ;;
mips-*-riscos*) fmt=ecoff ;;
- mips-*-linux-gnu*)
- fmt=elf em=tmips
- AC_DEFINE(MIPS_STABS_ELF, 1,
- [Use ELF stabs for MIPS, not ECOFF stabs])
- ;;
+ mips*-*-linux*) fmt=elf em=tmips mips_stabs_elf=y ;;
mips-*-sysv4*MP* | mips-*-gnu*)
fmt=elf em=tmips ;;
mips-*-sysv*) fmt=ecoff ;;
- mips-*-elf* | mips-*-rtems* | mips-*-openbsd*)
+ mips-*-elf* | mips-*-rtems* | mips-*-netbsd* | mips-*-openbsd*)
fmt=elf ;;
- mips-*-vxworks*) fmt=elf
- AC_DEFINE(MIPS_STABS_ELF, 1,
- [Use ELF stabs for MIPS, not ECOFF stabs])
- ;;
+ mips-*-vxworks*) fmt=elf mips_stabs_elf=y ;;
+ mmix-*-*) fmt=elf bfd_gas=yes ;;
mn10200-*-*) fmt=elf bfd_gas=yes ;;
mn10300-*-*) fmt=elf bfd_gas=yes ;;
+ openrisc-*-*) fmt=elf bfd_gas=yes ;;
pj*) fmt=elf ;;
ppc-*-pe | ppc-*-cygwin* | ppc-*-winnt*)
fmt=coff em=pe ;;
@@ -390,10 +403,20 @@ changequote([,])dnl
ppc-*-netware*) fmt=elf em=ppcnw ;;
ppc-*-vxworks*) fmt=elf ;;
- sh-*-linux*) fmt=elf em=linux ;;
+ s390x-*-linux-gnu*) fmt=elf em=linux ;;
+ s390-*-linux-gnu*) fmt=elf em=linux ;;
+
+ sh*-*-linux*) fmt=elf em=linux
+ case ${cpu} in
+ sh*eb)
+ endian=big ;;
+ sh*)
+ endian=little ;;
+ esac ;;
+ sh*-*-netbsdelf*) fmt=elf em=nbsd ;;
sh-*-elf*) fmt=elf ;;
sh-*-coff*) fmt=coff bfd_gas=yes;;
- sh-*-pe*) fmt=coff em=pe bfd_gas=yes;;
+ sh-*-pe*) fmt=coff em=pe bfd_gas=yes endian=little ;;
sh-*-rtemself*) fmt=elf ;;
sh-*-rtems*) fmt=coff bfd_gas=yes;;
@@ -444,12 +467,13 @@ changequote([,])dnl
fmt=aout ;;
vax-*-vms) fmt=vms ;;
+ w65-*-*) fmt=coff ;;
+
+ xstormy16-*-*) fmt=elf bfd_gas=yes ;;
z8k-*-coff | z8k-*-sim)
fmt=coff ;;
- w65-*-*) fmt=coff ;;
-
*-*-aout | *-*-scout)
fmt=aout ;;
*-*-freebsd*) fmt=elf em=freebsd bfd_gas=yes ;;
@@ -480,6 +504,11 @@ changequote([,])dnl
fi
fi
+ if test x${mips_stabs_elf} != x; then
+ AC_DEFINE(MIPS_STABS_ELF, 1,
+ [Use ELF stabs for MIPS, not ECOFF stabs])
+ fi
+
case ${cpu_type}-${fmt} in
alpha*-*) bfd_gas=yes ;;
arm-*) bfd_gas=yes ;;
@@ -488,6 +517,7 @@ changequote([,])dnl
ia64*-*) bfd_gas=yes ;;
mips-*) bfd_gas=yes ;;
ns32k-*) bfd_gas=yes ;;
+ pdp11-*) bfd_gas=yes ;;
ppc-*) bfd_gas=yes ;;
sparc-*) bfd_gas=yes ;;
strongarm-*) bfd_gas=yes ;;
@@ -526,7 +556,7 @@ changequote([,])dnl
# Any other special object files needed ?
case ${cpu_type} in
- fr30 | m32r)
+ fr30 | m32r | openrisc)
using_cgen=yes
;;
@@ -554,16 +584,16 @@ changequote([,])dnl
fi
;;
- i386)
+ i386 | s390 | sparc)
if test $this_target = $target ; then
AC_DEFINE_UNQUOTED(DEFAULT_ARCH, "${arch}", [Default architecture.])
fi
;;
- sparc)
- if test $this_target = $target ; then
- AC_DEFINE_UNQUOTED(DEFAULT_ARCH, "${arch}", [Default architecture.])
- fi
+
+ xstormy16)
+ using_cgen=yes
;;
+
*)
;;
esac
@@ -595,9 +625,9 @@ changequote([,])dnl
case ${generic_target}-${fmt} in
mips-*-irix5*-*) emulation="mipsbelf mipslelf mipself mipsbecoff mipslecoff mipsecoff" ;;
- mips-*-linux-gnu*-*) case "$endian" in
- big) emulation="mipsbelf mipslelf mipself mipsbecoff mipslecoff mipsecoff" ;;
- *) emulation="mipslelf mipsbelf mipself mipslecoff mipsbecoff mipsecoff" ;;
+ mips*-*-linux*-*) case "$endian" in
+ big) emulation="mipsbelf mipslelf mipself" ;;
+ *) emulation="mipslelf mipsbelf mipself" ;;
esac ;;
mips-*-lnews*-ecoff) ;;
mips-*-*-ecoff) case "$endian" in
@@ -652,6 +682,7 @@ fi
# is emulated.
case ${target_cpu} in
vax | tahoe ) atof=${target_cpu} ;;
+ pdp11) atof=vax ;;
*) atof=ieee ;;
esac
@@ -839,7 +870,7 @@ AC_PROG_CC
AC_PROG_YACC
AM_PROG_LEX
-ALL_LINGUAS=
+ALL_LINGUAS="fr tr"
CY_GNU_GETTEXT
AM_MAINTAINER_MODE
OpenPOWER on IntegriCloud