summaryrefslogtreecommitdiffstats
path: root/contrib/binutils/bfd/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/binutils/bfd/doc/Makefile.am')
-rw-r--r--contrib/binutils/bfd/doc/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/contrib/binutils/bfd/doc/Makefile.am b/contrib/binutils/bfd/doc/Makefile.am
index cbfd342..0787143 100644
--- a/contrib/binutils/bfd/doc/Makefile.am
+++ b/contrib/binutils/bfd/doc/Makefile.am
@@ -209,7 +209,9 @@ libbfd.h: $(LIBBFD_H_DEP)
case $$file in \
*-in.h) cat $$file >> $@ ;; \
*/header.sed) break ;; \
- *) ./$(MKDOC) -i -f $(srcdir)/proto.str < $$file >> $@ ;; \
+ *) echo $$file | sed -e 's,.*/,,' -e 's,^,/* Extracted from ,' \
+ -e 's,$$,. */,' >> $@ ; \
+ ./$(MKDOC) -i -f $(srcdir)/proto.str < $$file >> $@ ;; \
esac; \
done
@@ -226,7 +228,9 @@ libcoff.h: $(LIBCOFF_H_DEP)
case $$file in \
*-in.h) cat $$file >> $@ ;; \
*/header.sed) break ;; \
- *) ./$(MKDOC) -i -f $(srcdir)/proto.str < $$file >> $@ ;; \
+ *) echo $$file | sed -e 's,.*/,,' -e 's,^,/* Extracted from ,' \
+ -e 's,$$,. */,' >> $@ ; \
+ ./$(MKDOC) -i -f $(srcdir)/proto.str < $$file >> $@ ;; \
esac; \
done
@@ -255,7 +259,9 @@ bfd.h: $(BFD_H_DEP)
case $$file in \
*-in.h) cat $$file >> $@ ;; \
*/header.sed) break ;; \
- *) ./$(MKDOC) -f $(srcdir)/proto.str < $$file >> $@ ;; \
+ *) echo $$file | sed -e 's,.*/,,' -e 's,^,/* Extracted from ,' \
+ -e 's,$$,. */,' >> $@ ; \
+ ./$(MKDOC) -f $(srcdir)/proto.str < $$file >> $@ ;; \
esac; \
done
echo "#ifdef __cplusplus" >> $@
OpenPOWER on IntegriCloud