summaryrefslogtreecommitdiffstats
path: root/contrib/bind9/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/bind9/configure.in')
-rw-r--r--contrib/bind9/configure.in139
1 files changed, 123 insertions, 16 deletions
diff --git a/contrib/bind9/configure.in b/contrib/bind9/configure.in
index 8db8dde..8e543d8 100644
--- a/contrib/bind9/configure.in
+++ b/contrib/bind9/configure.in
@@ -18,7 +18,7 @@ AC_DIVERT_PUSH(1)dnl
esyscmd([sed "s/^/# /" COPYRIGHT])dnl
AC_DIVERT_POP()dnl
-AC_REVISION($Revision: 1.512.8.15 $)
+AC_REVISION($Revision: 1.533 $)
AC_INIT(lib/dns/name.c)
AC_PREREQ(2.59)
@@ -37,7 +37,7 @@ case $build_os in
sunos*)
# Just set the maximum command line length for sunos as it otherwise
# takes a exceptionally long time to work it out. Required for libtool.
-
+
lt_cv_sys_max_cmd_len=4096;
;;
esac
@@ -137,6 +137,73 @@ AC_PATH_PROGS(PERL, perl5 perl)
AC_SUBST(PERL)
#
+# Python is also optional; it is used by the tools in bin/python.
+# If python is unavailable, we simply don't build those.
+#
+AC_ARG_WITH(python,
+[ --with-python=PATH Specify path to python interpreter],
+ use_python="$withval", use_python="unspec")
+
+case "$use_python" in
+ no)
+ AC_MSG_RESULT(disabled)
+ ;;
+ unspec|yes|*)
+ case "$use_python" in
+ unspec|yes|'')
+ AC_PATH_PROGS(PYTHON, python)
+ ;;
+ *)
+ AC_PATH_PROGS(PYTHON, $use_python)
+ ;;
+ esac
+ if test "X$PYTHON" == "X"
+ then
+ case "$use_python" in
+ unspec)
+ AC_MSG_RESULT(disabled)
+ ;;
+ yes|*)
+ AC_MSG_ERROR([missing python])
+ ;;
+ esac
+ break
+ fi
+ testscript='try: import argparse
+except: exit(1)'
+ AC_MSG_CHECKING([python module 'argparse'])
+ if $PYTHON -c "$testscript"; then
+ AC_MSG_RESULT([found, using $PYTHON])
+ else
+ case "$use_python" in
+ unspec)
+ PYTHON=""
+ AC_SUBST(CHECKDS)
+ AC_SUBST(COVERAGE)
+ AC_MSG_RESULT([not found, python disabled])
+ ;;
+ yes)
+ AC_MSG_RESULT([no found])
+ AC_MSG_ERROR([python 'argparse' module not supported])
+ ;;
+ esac
+ fi
+ ;;
+esac
+
+PYTHON_TOOLS=''
+CHECKDS=''
+COVERAGE=''
+if test "X$PYTHON" != "X"; then
+ PYTHON_TOOLS=python
+ CHECKDS=checkds
+ COVERAGE=coverage
+fi
+AC_SUBST(CHECKDS)
+AC_SUBST(COVERAGE)
+AC_SUBST(PYTHON_TOOLS)
+
+#
# Special processing of paths depending on whether --prefix,
# --sysconfdir or --localstatedir arguments were given. What's
# desired is some compatibility with the way previous versions
@@ -399,6 +466,19 @@ lifconf.lifc_len = 0;
AC_SUBST(ISC_PLATFORM_HAVELIFCONF)
#
+# check if we want the new statistics
+#
+AC_ARG_ENABLE(newstats,
+ [ --enable-newstats use the new statistics])
+case "$enable_newstats" in
+yes)
+ AC_DEFINE(NEWSTATS, 1, [Use the new XML schema for statistics])
+ ;;
+*)
+ ;;
+esac
+
+#
# check if we have kqueue
#
AC_ARG_ENABLE(kqueue,
@@ -662,7 +742,7 @@ shared library configuration (e.g., LD_LIBRARY_PATH).)],
],
[AC_MSG_RESULT(assuming it does work on target platform)]
)
-
+
AC_ARG_ENABLE(openssl-version-check,
[AC_HELP_STRING([--enable-openssl-version-check],
[Check OpenSSL Version @<:@default=yes@:>@])])
@@ -1334,7 +1414,7 @@ AC_CHECK_LIB(scf, smf_enable_instance)
AC_CHECK_FUNC(flockfile, AC_DEFINE(HAVE_FLOCKFILE),)
AC_CHECK_FUNC(getc_unlocked, AC_DEFINE(HAVE_GETCUNLOCKED),)
-#
+#
# Indicate what the final decision was regarding threads.
#
AC_MSG_CHECKING(whether to build with threads)
@@ -1344,7 +1424,7 @@ else
AC_MSG_RESULT(no)
fi
-#
+#
# End of pthreads stuff.
#
@@ -1975,7 +2055,7 @@ AC_TRY_RUN([
#include <netinet/in.h>
#include <arpa/inet.h>
main() { char a[16]; return (inet_pton(AF_INET, "1.2.3", a) == 1 ? 1 :
- inet_pton(AF_INET, "1.2.3.04", a) == 1 ? 1 :
+ inet_pton(AF_INET, "1.2.3.04", a) == 1 ? 1 :
(inet_pton(AF_INET6, "::1.2.3.4", a) != 1)); }],
[AC_MSG_RESULT(yes)
ISC_PLATFORM_NEEDPTON="#undef ISC_PLATFORM_NEEDPTON"],
@@ -2216,7 +2296,7 @@ AC_ARG_ENABLE(getifaddrs,
# This interface iteration code for getifaddrs() will fall back to using
# /proc/net/if_inet6 if getifaddrs() in glibc doesn't return any IPv6
# addresses.
-#
+#
case $want_getifaddrs in
glibc)
AC_MSG_WARN("--enable-getifaddrs=glibc is no longer required")
@@ -2291,6 +2371,29 @@ AC_CHECK_FUNC(strlcat,
[ISC_PLATFORM_NEEDSTRLCAT="#define ISC_PLATFORM_NEEDSTRLCAT 1"])
AC_SUBST(ISC_PLATFORM_NEEDSTRLCAT)
+
+AC_SUBST(READLINE_LIB)
+AC_ARG_WITH(readline,
+ [ --with-readline[=LIBSPEC] specify readline library [default -lreadline]],
+ readline="$withval", readline="-lreadline")
+case "$readline" in
+no) ;;
+*)
+ if test "x$readline" = "xyes"
+ then
+ readline=-lreadline
+ fi
+ saved_LIBS="$LIBS"
+ LIBS="$readline"
+ AC_CHECK_FUNCS(readline)
+ if test "$ac_cv_func_readline" = "yes"
+ then
+ READLINE_LIB="$readline"
+ fi
+ LIBS="$saved_LIBS"
+ ;;
+esac
+
ISC_PRINT_OBJS=
ISC_PRINT_SRCS=
AC_MSG_CHECKING(sprintf)
@@ -2376,7 +2479,7 @@ main() {
sprintf(buf, "%lld", j);
exit((sizeof(long long int) != sizeof(long int))? 0 :
(strcmp(buf, "0") != 0));
-}
+}
],
[AC_MSG_RESULT(ll)
ISC_PLATFORM_QUADFORMAT='#define ISC_PLATFORM_QUADFORMAT "ll"'
@@ -2641,7 +2744,7 @@ yes)
esac
AC_SUBST(ISC_PLATFORM_HAVEIFNAMETOINDEX)
-AC_CHECK_FUNCS(nanosleep)
+AC_CHECK_FUNCS(nanosleep usleep)
#
# Machine architecture dependent features
@@ -2768,7 +2871,7 @@ if test "$have_atomic" = "yes"; then
else
case "$host" in
alpha*-dec-osf*)
- # Tru64 compiler has its own syntax for inline
+ # Tru64 compiler has its own syntax for inline
# assembly.
AC_TRY_COMPILE(, [
#ifndef __DECC
@@ -2990,11 +3093,11 @@ AC_SUBST(DOXYGEN)
# NOM_PATH_FILE(VARIABLE, FILENAME, DIRECTORIES)
#
# If the file FILENAME is found in one of the DIRECTORIES, the shell
-# variable VARIABLE is defined to its absolute pathname. Otherwise,
+# variable VARIABLE is defined to its absolute pathname. Otherwise,
# it is set to FILENAME, with no directory prefix (that's not terribly
# useful, but looks less confusing in substitutions than leaving it
# empty). The variable VARIABLE will be substituted into output files.
-#
+#
AC_DEFUN(NOM_PATH_FILE, [
$1=""
@@ -3304,7 +3407,7 @@ DLZ_DRIVER_SRCS=""
DLZ_DRIVER_OBJS=""
DLZ_SYSTEM_TEST=""
-#
+#
# Configure support for building a shared library object
#
# Even when libtool is available it can't always be relied upon
@@ -3415,8 +3518,8 @@ if test "$cross_compiling" = "yes"; then
BUILD_LDFLAGS="$BUILD_LDFLAGS"
BUILD_LIBS="$BUILD_LIBS"
else
- BUILD_CC="$CC"
- BUILD_CFLAGS="$CFLAGS"
+ BUILD_CC="$CC"
+ BUILD_CFLAGS="$CFLAGS"
BUILD_CPPFLAGS="$CPPFLAGS $GEN_NEED_OPTARG"
BUILD_LDFLAGS="$LDFLAGS"
BUILD_LIBS="$LIBS"
@@ -3545,6 +3648,9 @@ AC_CONFIG_FILES([
bin/named/unix/Makefile
bin/nsupdate/Makefile
bin/pkcs11/Makefile
+ bin/python/Makefile
+ bin/python/dnssec-checkds.py
+ bin/python/dnssec-coverage.py
bin/rndc/Makefile
bin/tests/Makefile
bin/tests/atomic/Makefile
@@ -3584,6 +3690,7 @@ AC_CONFIG_FILES([
bin/tests/system/gost/prereq.sh
bin/tests/system/lwresd/Makefile
bin/tests/system/rpz/Makefile
+ bin/tests/system/rsabigexponent/Makefile
bin/tests/system/tkey/Makefile
bin/tests/system/tsiggss/Makefile
bin/tests/tasks/Makefile
@@ -3698,7 +3805,7 @@ yes)
esac
if test "X$USE_OPENSSL" = "X"; then
-cat << \EOF
+cat << \EOF
BIND is being built without OpenSSL. This means it will not have DNSSEC support.
EOF
fi
OpenPOWER on IntegriCloud