summaryrefslogtreecommitdiffstats
path: root/contrib/bc/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/bc/lib/Makefile.am')
-rw-r--r--contrib/bc/lib/Makefile.am23
1 files changed, 20 insertions, 3 deletions
diff --git a/contrib/bc/lib/Makefile.am b/contrib/bc/lib/Makefile.am
index bf33e3f..6f74b4d 100644
--- a/contrib/bc/lib/Makefile.am
+++ b/contrib/bc/lib/Makefile.am
@@ -1,9 +1,26 @@
## Process this file with automake to produce Makefile.in
noinst_LIBRARIES = libbc.a
-INCLUDES = -I$(srcdir) -I$(srcdir)/../h
+INCLUDES = -I. -I.. -I$(srcdir)/../h
libbc_a_SOURCES = getopt.c getopt1.c vfprintf.c number.c
-#libbc_LIBADD = @LIBOBJS@
-#libbc_DEPENDENCIES = $(bc_LIBADD)
+DEFS = @DEFS@ $(DEFSADD)
+
+CFLAGS = @CFLAGS@ -Wall -funsigned-char
+
+MAINTAINERCLEANFILES = Makefile.in number.c
+
+newnumber.o: number.c muldigits.h
+ $(CC) $(CFLAGS) $(INCLUDES) -c -DMULDIGITS -o newnumber.o $(srcdir)/number.c
+
+muldigits.h: testmul
+ @echo "The following may take up to 10 minutes."
+ testmul > muldigits.h
+
+testmul: testmul.o number.o
+ $(CC) $(CFLAGS) -o testmul testmul.o number.o
+
+specialnumber: newnumber.o
+ cp newnumber.o number.o
+
OpenPOWER on IntegriCloud