summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorrdivacky <rdivacky@FreeBSD.org>2009-12-01 11:08:04 +0000
committerrdivacky <rdivacky@FreeBSD.org>2009-12-01 11:08:04 +0000
commit4b08eb6308ca90a6c08e2fc79d100821b1b1f6aa (patch)
tree867cbbe32a66fd7d62dd9ce9df23a23fefdb8290 /test/CMakeLists.txt
parent6df2408694f81a03eb8b0e3b013272042233c061 (diff)
downloadFreeBSD-src-4b08eb6308ca90a6c08e2fc79d100821b1b1f6aa.zip
FreeBSD-src-4b08eb6308ca90a6c08e2fc79d100821b1b1f6aa.tar.gz
Update clang to r90226.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index cd822f6..f39eb2a 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -40,6 +40,11 @@ if(PYTHONINTERP_FOUND)
set(CLANG_TEST_EXTRA_ARGS "--no-progress-bar")
endif()
+ option(CLANG_TEST_USE_VG "Run Clang tests under Valgrind" OFF)
+ if(CLANG_TEST_USE_VG)
+ set(CLANG_TEST_EXTRA_ARGS ${CLANG_TEST_EXTRA_ARGS} "--vg")
+ endif ()
+
foreach(testdir ${CLANG_TEST_DIRECTORIES})
add_custom_target(clang-test-${testdir}
COMMAND ${PYTHON_EXECUTABLE}
OpenPOWER on IntegriCloud