summaryrefslogtreecommitdiffstats
path: root/lib/Lex/CMakeLists.txt
diff options
context:
space:
mode:
authored <ed@FreeBSD.org>2009-06-02 17:58:47 +0000
committered <ed@FreeBSD.org>2009-06-02 17:58:47 +0000
commitf27e5a09a0d815b8a4814152954ff87dadfdefc0 (patch)
treece7d964cbb5e39695b71481698f10cb099c23d4a /lib/Lex/CMakeLists.txt
downloadFreeBSD-src-f27e5a09a0d815b8a4814152954ff87dadfdefc0.zip
FreeBSD-src-f27e5a09a0d815b8a4814152954ff87dadfdefc0.tar.gz
Import Clang, at r72732.
Diffstat (limited to 'lib/Lex/CMakeLists.txt')
-rw-r--r--lib/Lex/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/lib/Lex/CMakeLists.txt b/lib/Lex/CMakeLists.txt
new file mode 100644
index 0000000..a7237a7
--- /dev/null
+++ b/lib/Lex/CMakeLists.txt
@@ -0,0 +1,26 @@
+set(LLVM_NO_RTTI 1)
+
+# TODO: Add -maltivec when ARCH is PowerPC.
+
+add_clang_library(clangLex
+ HeaderMap.cpp
+ HeaderSearch.cpp
+ Lexer.cpp
+ LiteralSupport.cpp
+ MacroArgs.cpp
+ MacroInfo.cpp
+ PPCaching.cpp
+ PPDirectives.cpp
+ PPExpressions.cpp
+ PPLexerChange.cpp
+ PPMacroExpansion.cpp
+ Pragma.cpp
+ Preprocessor.cpp
+ PreprocessorLexer.cpp
+ PTHLexer.cpp
+ ScratchBuffer.cpp
+ TokenLexer.cpp
+ TokenConcatenation.cpp
+ )
+
+add_dependencies(clangLex ClangDiagnosticLex)
OpenPOWER on IntegriCloud