summaryrefslogtreecommitdiffstats
path: root/lib/Headers/CMakeLists.txt
diff options
context:
space:
mode:
authorrdivacky <rdivacky@FreeBSD.org>2009-10-14 18:03:49 +0000
committerrdivacky <rdivacky@FreeBSD.org>2009-10-14 18:03:49 +0000
commit9092c3e0fa01f3139b016d05d267a89e3b07747a (patch)
tree137ebebcae16fb0ce7ab4af456992bbd8d22fced /lib/Headers/CMakeLists.txt
parent4981926bf654fe5a2c3893f24ca44106b217e71e (diff)
downloadFreeBSD-src-9092c3e0fa01f3139b016d05d267a89e3b07747a.zip
FreeBSD-src-9092c3e0fa01f3139b016d05d267a89e3b07747a.tar.gz
Update clang to r84119.
Diffstat (limited to 'lib/Headers/CMakeLists.txt')
-rw-r--r--lib/Headers/CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/lib/Headers/CMakeLists.txt b/lib/Headers/CMakeLists.txt
index 57d7ee5..6c874f4 100644
--- a/lib/Headers/CMakeLists.txt
+++ b/lib/Headers/CMakeLists.txt
@@ -14,11 +14,10 @@ set(files
tmmintrin.h
xmmintrin.h)
-#FIXME: Centralize Clang version info
if (MSVC_IDE OR XCODE)
- set(output_dir ${LLVM_BINARY_DIR}/bin/lib/clang/1.0/include)
+ set(output_dir ${LLVM_BINARY_DIR}/bin/lib/clang/${CLANG_VERSION}/include)
else ()
- set(output_dir ${LLVM_BINARY_DIR}/lib/clang/1.0/include)
+ set(output_dir ${LLVM_BINARY_DIR}/lib/clang/${CLANG_VERSION}/include)
endif ()
@@ -36,4 +35,4 @@ add_custom_target(clang-headers ALL
install(FILES ${files}
PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ
- DESTINATION Headers)
+ DESTINATION lib/clang/${CLANG_VERSION}/include)
OpenPOWER on IntegriCloud