summaryrefslogtreecommitdiffstats
path: root/crypto/heimdal/packages/debian/patches
diff options
context:
space:
mode:
authordfr <dfr@FreeBSD.org>2008-05-07 13:39:42 +0000
committerdfr <dfr@FreeBSD.org>2008-05-07 13:39:42 +0000
commit52bf09d8197dd1ec84e1ab72684f2058f0eae9e1 (patch)
tree07a0d6761d1b42410a27e4c7d583b766d6671f80 /crypto/heimdal/packages/debian/patches
parent6c68306921f6e85bce52c905cf2606c25acdb436 (diff)
parent51b6601db456e699ea5d4843cbc7239ee92d9c13 (diff)
downloadFreeBSD-src-52bf09d8197dd1ec84e1ab72684f2058f0eae9e1.zip
FreeBSD-src-52bf09d8197dd1ec84e1ab72684f2058f0eae9e1.tar.gz
This commit was generated by cvs2svn to compensate for changes in r178825,
which included commits to RCS files with non-trunk default branches.
Diffstat (limited to 'crypto/heimdal/packages/debian/patches')
-rw-r--r--crypto/heimdal/packages/debian/patches/021_debian204
-rw-r--r--crypto/heimdal/packages/debian/patches/022_ftp-roken-glob270
-rw-r--r--crypto/heimdal/packages/debian/patches/022_openafs15
-rw-r--r--crypto/heimdal/packages/debian/patches/025_pthreads13
-rw-r--r--crypto/heimdal/packages/debian/patches/026_posix_max293
5 files changed, 795 insertions, 0 deletions
diff --git a/crypto/heimdal/packages/debian/patches/021_debian b/crypto/heimdal/packages/debian/patches/021_debian
new file mode 100644
index 0000000..52d1990
--- /dev/null
+++ b/crypto/heimdal/packages/debian/patches/021_debian
@@ -0,0 +1,204 @@
+Index: heimdal-0.7.2.dfsg.1/lib/hdb/hdb.h
+===================================================================
+--- heimdal-0.7.2.dfsg.1.orig/lib/hdb/hdb.h 2006-05-13 16:42:53.000000000 +1000
++++ heimdal-0.7.2.dfsg.1/lib/hdb/hdb.h 2006-05-13 16:42:58.000000000 +1000
+@@ -86,7 +86,7 @@
+ krb5_error_code (*create)(krb5_context, HDB **, const char *filename);
+ };
+
+-#define HDB_DB_DIR "/var/heimdal"
++#define HDB_DB_DIR "/var/lib/heimdal-kdc"
+ #define HDB_DEFAULT_DB HDB_DB_DIR "/heimdal"
+ #define HDB_DB_FORMAT_ENTRY "hdb/db-format"
+
+Index: heimdal-0.7.2.dfsg.1/appl/telnet/telnetd/telnetd.h
+===================================================================
+--- heimdal-0.7.2.dfsg.1.orig/appl/telnet/telnetd/telnetd.h 2006-05-13 16:42:53.000000000 +1000
++++ heimdal-0.7.2.dfsg.1/appl/telnet/telnetd/telnetd.h 2006-05-13 16:42:58.000000000 +1000
+@@ -192,7 +192,7 @@
+ #endif
+
+ #undef _PATH_LOGIN
+-#define _PATH_LOGIN BINDIR "/login"
++#define _PATH_LOGIN "/bin/login"
+
+ /* fallbacks */
+
+Index: heimdal-0.7.2.dfsg.1/kdc/kdc.8
+===================================================================
+--- heimdal-0.7.2.dfsg.1.orig/kdc/kdc.8 2006-05-13 16:42:53.000000000 +1000
++++ heimdal-0.7.2.dfsg.1/kdc/kdc.8 2006-05-13 16:42:58.000000000 +1000
+@@ -77,7 +77,7 @@
+ .Fl -config-file= Ns Ar file
+ .Xc
+ Specifies the location of the config file, the default is
+-.Pa /var/heimdal/kdc.conf .
++.Pa /etc/heimdal-kdc/kdc.conf .
+ This is the only value that can't be specified in the config file.
+ .It Xo
+ .Fl p ,
+Index: heimdal-0.7.2.dfsg.1/doc/setup.texi
+===================================================================
+--- heimdal-0.7.2.dfsg.1.orig/doc/setup.texi 2006-05-13 16:42:53.000000000 +1000
++++ heimdal-0.7.2.dfsg.1/doc/setup.texi 2006-05-13 16:42:58.000000000 +1000
+@@ -335,7 +335,7 @@
+ as @samp{749/tcp}.
+
+ Access to the administration server is controlled by an ACL file, (default
+-@file{/var/heimdal/kadmind.acl}.) The lines in the access file, have the
++@file{/etc/heimdal-kdc/kadmind.acl}.) The lines in the access file, have the
+ following syntax:
+ @smallexample
+ principal [priv1,priv2,...] [glob-pattern]
+Index: heimdal-0.7.2.dfsg.1/kdc/kdc_locl.h
+===================================================================
+--- heimdal-0.7.2.dfsg.1.orig/kdc/kdc_locl.h 2006-05-13 16:42:53.000000000 +1000
++++ heimdal-0.7.2.dfsg.1/kdc/kdc_locl.h 2006-05-13 16:42:58.000000000 +1000
+@@ -74,7 +74,7 @@
+ extern int enable_pkinit_princ_in_cert;
+ #endif
+
+-#define _PATH_KDC_CONF HDB_DB_DIR "/kdc.conf"
++#define _PATH_KDC_CONF "/etc/heimdal-kdc/kdc.conf"
+ #define DEFAULT_LOG_DEST "0-1/FILE:" HDB_DB_DIR "/kdc.log"
+
+ extern struct timeval now;
+Index: heimdal-0.7.2.dfsg.1/lib/kadm5/context_s.c
+===================================================================
+--- heimdal-0.7.2.dfsg.1.orig/lib/kadm5/context_s.c 2006-05-13 16:42:53.000000000 +1000
++++ heimdal-0.7.2.dfsg.1/lib/kadm5/context_s.c 2006-05-13 16:42:58.000000000 +1000
+@@ -158,7 +158,7 @@
+ set_config(ctx, default_binding);
+ else {
+ ctx->config.dbname = strdup(HDB_DEFAULT_DB);
+- ctx->config.acl_file = strdup(HDB_DB_DIR "/kadmind.acl");
++ ctx->config.acl_file = strdup("/etc/heimdal-kdc/kadmind.acl");
+ ctx->config.stash_file = strdup(HDB_DB_DIR "/m-key");
+ ctx->log_context.log_file = strdup(HDB_DB_DIR "/log");
+ memset(&ctx->log_context.socket_name, 0,
+Index: heimdal-0.7.2.dfsg.1/kadmin/kadmind.8
+===================================================================
+--- heimdal-0.7.2.dfsg.1.orig/kadmin/kadmind.8 2006-05-13 16:42:53.000000000 +1000
++++ heimdal-0.7.2.dfsg.1/kadmin/kadmind.8 2006-05-13 16:42:58.000000000 +1000
+@@ -85,7 +85,7 @@
+ Principals are always allowed to change their own password and list
+ their own principal. Apart from that, doing any operation requires
+ permission explicitly added in the ACL file
+-.Pa /var/heimdal/kadmind.acl .
++.Pa /etc/heimdal-kdc/kadmind.acl .
+ The format of this file is:
+ .Bd -ragged
+ .Va principal
+@@ -155,7 +155,7 @@
+ .El
+ .\".Sh ENVIRONMENT
+ .Sh FILES
+-.Pa /var/heimdal/kadmind.acl
++.Pa /etc/heimdal-kdc/kadmind.acl
+ .Sh EXAMPLES
+ This will cause
+ .Nm
+Index: heimdal-0.7.2.dfsg.1/lib/kadm5/truncate_log.c
+===================================================================
+--- heimdal-0.7.2.dfsg.1.orig/lib/kadm5/truncate_log.c 2003-11-19 10:19:26.000000000 +1100
++++ heimdal-0.7.2.dfsg.1/lib/kadm5/truncate_log.c 2006-05-14 10:33:39.054471619 +1000
+@@ -69,7 +69,7 @@
+ }
+
+ if (config_file == NULL)
+- config_file = HDB_DB_DIR "/kdc.conf";
++ config_file = "/etc/heimdal-kdc/kdc.conf";
+
+ ret = krb5_prepend_config_files_default(config_file, &files);
+ if (ret)
+Index: heimdal-0.7.2.dfsg.1/lib/kadm5/dump_log.c
+===================================================================
+--- heimdal-0.7.2.dfsg.1.orig/lib/kadm5/dump_log.c 2005-04-26 04:17:51.000000000 +1000
++++ heimdal-0.7.2.dfsg.1/lib/kadm5/dump_log.c 2006-05-14 10:33:13.743359875 +1000
+@@ -246,7 +246,7 @@
+ }
+
+ if (config_file == NULL)
+- config_file = HDB_DB_DIR "/kdc.conf";
++ config_file = "/etc/heimdal-kdc/kdc.conf";
+
+ ret = krb5_prepend_config_files_default(config_file, &files);
+ if (ret)
+Index: heimdal-0.7.2.dfsg.1/kadmin/kadmind.c
+===================================================================
+--- heimdal-0.7.2.dfsg.1.orig/kadmin/kadmind.c 2005-04-15 21:16:32.000000000 +1000
++++ heimdal-0.7.2.dfsg.1/kadmin/kadmind.c 2006-05-14 10:27:22.837834789 +1000
+@@ -117,7 +117,7 @@
+ argv += optind;
+
+ if (config_file == NULL)
+- config_file = HDB_DB_DIR "/kdc.conf";
++ config_file = "/etc/heimdal-kdc/kdc.conf";
+
+ ret = krb5_prepend_config_files_default(config_file, &files);
+ if (ret)
+Index: heimdal-0.7.2.dfsg.1/kadmin/kadmin.c
+===================================================================
+--- heimdal-0.7.2.dfsg.1.orig/kadmin/kadmin.c 2005-05-10 01:35:22.000000000 +1000
++++ heimdal-0.7.2.dfsg.1/kadmin/kadmin.c 2006-05-14 10:27:03.969138000 +1000
+@@ -194,7 +194,7 @@
+ argv += optind;
+
+ if (config_file == NULL)
+- config_file = HDB_DB_DIR "/kdc.conf";
++ config_file = "/etc/heimdal-kdc/kdc.conf";
+
+ ret = krb5_prepend_config_files_default(config_file, &files);
+ if (ret)
+Index: heimdal-0.7.2.dfsg.1/lib/kadm5/replay_log.c
+===================================================================
+--- heimdal-0.7.2.dfsg.1.orig/lib/kadm5/replay_log.c 2003-11-19 10:19:22.000000000 +1100
++++ heimdal-0.7.2.dfsg.1/lib/kadm5/replay_log.c 2006-05-14 10:33:28.976621605 +1000
+@@ -99,7 +99,7 @@
+ }
+
+ if (config_file == NULL)
+- config_file = HDB_DB_DIR "/kdc.conf";
++ config_file = "/etc/heimdal-kdc/kdc.conf";
+
+ ret = krb5_prepend_config_files_default(config_file, &files);
+ if (ret)
+Index: heimdal-0.7.2.dfsg.1/lib/kadm5/ipropd_slave.c
+===================================================================
+--- heimdal-0.7.2.dfsg.1.orig/lib/kadm5/ipropd_slave.c 2005-05-24 03:39:35.000000000 +1000
++++ heimdal-0.7.2.dfsg.1/lib/kadm5/ipropd_slave.c 2006-05-14 10:31:34.812853916 +1000
+@@ -418,7 +418,7 @@
+ }
+
+ if (config_file == NULL)
+- config_file = HDB_DB_DIR "/kdc.conf";
++ config_file = "/etc/heimdal-kdc/kdc.conf";
+
+ ret = krb5_prepend_config_files_default(config_file, &files);
+ if (ret)
+Index: heimdal-0.7.2.dfsg.1/lib/kadm5/ipropd_master.c
+===================================================================
+--- heimdal-0.7.2.dfsg.1.orig/lib/kadm5/ipropd_master.c 2005-05-24 03:38:46.000000000 +1000
++++ heimdal-0.7.2.dfsg.1/lib/kadm5/ipropd_master.c 2006-05-14 10:31:17.286905672 +1000
+@@ -654,7 +654,7 @@
+ }
+
+ if (config_file == NULL)
+- config_file = HDB_DB_DIR "/kdc.conf";
++ config_file = "/etc/heimdal-kdc/kdc.conf";
+
+ ret = krb5_prepend_config_files_default(config_file, &files);
+ if (ret)
+Index: heimdal-0.7.2.dfsg.1/kpasswd/kpasswdd.c
+===================================================================
+--- heimdal-0.7.2.dfsg.1.orig/kpasswd/kpasswdd.c 2005-04-22 21:03:11.000000000 +1000
++++ heimdal-0.7.2.dfsg.1/kpasswd/kpasswdd.c 2006-05-14 10:27:49.778564590 +1000
+@@ -749,7 +749,7 @@
+ }
+
+ if (config_file == NULL)
+- config_file = HDB_DB_DIR "/kdc.conf";
++ config_file = "/etc/heimdal-kdc/kdc.conf";
+
+ ret = krb5_prepend_config_files_default(config_file, &files);
+ if (ret)
diff --git a/crypto/heimdal/packages/debian/patches/022_ftp-roken-glob b/crypto/heimdal/packages/debian/patches/022_ftp-roken-glob
new file mode 100644
index 0000000..bd974da
--- /dev/null
+++ b/crypto/heimdal/packages/debian/patches/022_ftp-roken-glob
@@ -0,0 +1,270 @@
+Index: heimdal-0.7.2/appl/ftp/ftp/cmds.c
+===================================================================
+--- heimdal-0.7.2.orig/appl/ftp/ftp/cmds.c 2005-04-18 17:45:12.000000000 +1000
++++ heimdal-0.7.2/appl/ftp/ftp/cmds.c 2006-03-09 12:50:02.997025112 +1100
+@@ -536,9 +536,17 @@
+
+ memset(&gl, 0, sizeof(gl));
+ flags = GLOB_BRACE|GLOB_NOCHECK|GLOB_QUOTE|GLOB_TILDE;
++#ifdef HAVE_GLOB
+ if (glob(argv[i], flags, NULL, &gl) || gl.gl_pathc == 0) {
++#else
++ if (roken_glob(argv[i], flags, NULL, &gl) || gl.gl_pathc == 0) {
++#endif
+ warnx("%s: not found", argv[i]);
++#ifdef HAVE_GLOB
+ globfree(&gl);
++#else
++ roken_globfree(&gl);
++#endif
+ continue;
+ }
+ for (cpp = gl.gl_pathv; cpp && *cpp != NULL; cpp++) {
+@@ -559,7 +567,11 @@
+ }
+ }
+ }
++#ifdef HAVE_GLOB
+ globfree(&gl);
++#else
++ roken_globfree(&gl);
++#endif
+ }
+ signal(SIGINT, oldintr);
+ mflag = 0;
+@@ -1568,14 +1580,27 @@
+
+ flags = GLOB_BRACE|GLOB_NOCHECK|GLOB_QUOTE|GLOB_TILDE;
+ memset(&gl, 0, sizeof(gl));
++#ifdef HAVE_GLOB
+ if (glob(*cpp, flags, NULL, &gl) ||
++#else
++ if (roken_glob(*cpp, flags, NULL, &gl) ||
++#endif
+ gl.gl_pathc == 0) {
+ warnx("%s: not found", *cpp);
++#ifdef HAVE_GLOB
+ globfree(&gl);
++#else
++ roken_globfree(&gl);
++#endif
+ return (0);
+ }
+ *cpp = strdup(gl.gl_pathv[0]); /* XXX - wasted memory */
++#ifdef HAVE_GLOB
+ globfree(&gl);
++#else
++ roken_globfree(&gl);
++#endif
++
+ return (1);
+ }
+
+Index: heimdal-0.7.2/appl/ftp/ftp/ftp_locl.h
+===================================================================
+--- heimdal-0.7.2.orig/appl/ftp/ftp/ftp_locl.h 2002-09-11 06:03:46.000000000 +1000
++++ heimdal-0.7.2/appl/ftp/ftp/ftp_locl.h 2006-03-09 12:50:02.998024960 +1100
+@@ -101,7 +101,11 @@
+
+ #include <errno.h>
+ #include <ctype.h>
++#ifdef HAVE_GLOB
+ #include <glob.h>
++#else
++#include <roken-glob.h>
++#endif
+ #ifdef HAVE_NETDB_H
+ #include <netdb.h>
+ #endif
+Index: heimdal-0.7.2/appl/ftp/ftpd/ftpcmd.y
+===================================================================
+--- heimdal-0.7.2.orig/appl/ftp/ftpd/ftpcmd.y 2004-08-20 23:31:19.000000000 +1000
++++ heimdal-0.7.2/appl/ftp/ftpd/ftpcmd.y 2006-03-09 12:50:03.000024656 +1100
+@@ -826,14 +826,22 @@
+ GLOB_BRACE|GLOB_NOCHECK|GLOB_QUOTE|GLOB_TILDE;
+
+ memset(&gl, 0, sizeof(gl));
++#ifdef HAVE_GLOB
+ if (glob($1, flags, NULL, &gl) ||
++#else
++ if (roken_glob($1, flags, NULL, &gl) ||
++#endif
+ gl.gl_pathc == 0) {
+ reply(550, "not found");
+ $$ = NULL;
+ } else {
+ $$ = strdup(gl.gl_pathv[0]);
+ }
++#ifdef HAVE_GLOB
+ globfree(&gl);
++#else
++ roken_globfree(&gl);
++#endif
+ free($1);
+ } else
+ $$ = $1;
+Index: heimdal-0.7.2/appl/ftp/ftpd/ftpd.c
+===================================================================
+--- heimdal-0.7.2.orig/appl/ftp/ftpd/ftpd.c 2005-06-02 20:41:28.000000000 +1000
++++ heimdal-0.7.2/appl/ftp/ftpd/ftpd.c 2006-03-09 12:50:03.003024200 +1100
+@@ -2234,7 +2234,11 @@
+
+ memset(&gl, 0, sizeof(gl));
+ freeglob = 1;
++#ifdef HAVE_GLOB
+ if (glob(whichf, flags, 0, &gl)) {
++#else
++ if (roken_glob(whichf, flags, 0, &gl)) {
++#endif
+ reply(550, "not found");
+ goto out;
+ } else if (gl.gl_pathc == 0) {
+@@ -2341,7 +2345,11 @@
+ pdata = -1;
+ if (freeglob) {
+ freeglob = 0;
++#ifdef HAVE_GLOB
+ globfree(&gl);
++#else
++ roken_globfree(&gl);
++#endif
+ }
+ }
+
+Index: heimdal-0.7.2/appl/ftp/ftpd/ftpd_locl.h
+===================================================================
+--- heimdal-0.7.2.orig/appl/ftp/ftpd/ftpd_locl.h 2005-04-25 05:58:14.000000000 +1000
++++ heimdal-0.7.2/appl/ftp/ftpd/ftpd_locl.h 2006-03-09 12:50:03.004024048 +1100
+@@ -106,7 +106,11 @@
+ #ifdef HAVE_FCNTL_H
+ #include <fcntl.h>
+ #endif
++#ifdef HAVE_GLOB
+ #include <glob.h>
++#else
++#include <roken-glob.h>
++#endif
+ #include <limits.h>
+ #ifdef HAVE_PWD_H
+ #include <pwd.h>
+Index: heimdal-0.7.2/appl/ftp/ftpd/popen.c
+===================================================================
+--- heimdal-0.7.2.orig/appl/ftp/ftpd/popen.c 2002-04-02 21:57:39.000000000 +1000
++++ heimdal-0.7.2/appl/ftp/ftpd/popen.c 2006-03-09 12:50:03.013022680 +1100
+@@ -55,7 +55,11 @@
+ #include <sys/wait.h>
+
+ #include <errno.h>
++#ifdef HAVE_GLOB
+ #include <glob.h>
++#else
++#include <roken-glob.h>
++#endif
+ #include <signal.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+@@ -149,7 +153,11 @@
+
+ memset(&gl, 0, sizeof(gl));
+ if (no_glob ||
++#ifdef HAVE_GLOB
+ glob(argv[argc], flags, NULL, &gl) ||
++#else
++ roken_glob(argv[argc], flags, NULL, &gl) ||
++#endif
+ gl.gl_pathc == 0)
+ gargv[gargc++] = strdup(argv[argc]);
+ else
+@@ -157,7 +165,11 @@
+ *pop && gargc < MAXGLOBS - 1;
+ pop++)
+ gargv[gargc++] = strdup(*pop);
++#ifdef HAVE_GLOB
+ globfree(&gl);
++#else
++ roken_globfree(&gl);
++#endif
+ }
+ gargv[gargc] = NULL;
+
+Index: heimdal-0.7.2/lib/roken/glob.c
+===================================================================
+--- heimdal-0.7.2.orig/lib/roken/glob.c 2005-04-12 21:28:50.000000000 +1000
++++ heimdal-0.7.2/lib/roken/glob.c 2006-03-09 12:50:03.015022376 +1100
+@@ -87,7 +87,7 @@
+ #include <limits.h>
+ #endif
+
+-#include "glob.h"
++#include "roken-glob.h"
+ #include "roken.h"
+
+ #ifndef ARG_MAX
+@@ -167,7 +167,7 @@
+ #endif
+
+ int ROKEN_LIB_FUNCTION
+-glob(const char *pattern,
++roken_glob(const char *pattern,
+ int flags,
+ int (*errfunc)(const char *, int),
+ glob_t *pglob)
+@@ -742,7 +742,7 @@
+
+ /* Free allocated data belonging to a glob_t structure. */
+ void ROKEN_LIB_FUNCTION
+-globfree(glob_t *pglob)
++roken_globfree(glob_t *pglob)
+ {
+ int i;
+ char **pp;
+Index: heimdal-0.7.2/lib/roken/glob.hin
+===================================================================
+--- heimdal-0.7.2.orig/lib/roken/glob.hin 2005-04-13 23:17:56.000000000 +1000
++++ heimdal-0.7.2/lib/roken/glob.hin 2006-03-09 12:50:03.016022224 +1100
+@@ -32,8 +32,8 @@
+ * @(#)glob.h 8.1 (Berkeley) 6/2/93
+ */
+
+-#ifndef _GLOB_H_
+-#define _GLOB_H_
++#ifndef _ROKEN_GLOB_H_
++#define _ROKEN_GLOB_H_
+
+ #ifndef ROKEN_LIB_FUNCTION
+ #ifdef _WIN32
+@@ -88,9 +88,9 @@
+ #define GLOB_ABEND (-2) /* Unignored error. */
+
+ int ROKEN_LIB_FUNCTION
+-glob (const char *, int, int (*)(const char *, int), glob_t *);
++roken_glob (const char *, int, int (*)(const char *, int), glob_t *);
+
+ void ROKEN_LIB_FUNCTION
+-globfree (glob_t *);
++roken_globfree (glob_t *);
+
+-#endif /* !_GLOB_H_ */
++#endif /* !_ROKEN_GLOB_H_ */
+Index: heimdal-0.7.2/lib/roken/Makefile.am
+===================================================================
+--- heimdal-0.7.2.orig/lib/roken/Makefile.am 2005-05-24 21:39:01.000000000 +1000
++++ heimdal-0.7.2/lib/roken/Makefile.am 2006-03-09 12:50:03.016022224 +1100
+@@ -129,7 +129,7 @@
+ if have_glob_h
+ glob_h =
+ else
+-glob_h = glob.h
++glob_h = roken-glob.h
+ endif
+
+ if have_ifaddrs_h
+@@ -170,6 +170,8 @@
+ SUFFIXES += .hin
+ .hin.h:
+ cp $< $@
++roken-glob.h:
++ cp glob.hin roken-glob.h
+
+ roken.h: make-roken$(EXEEXT)
+ @./make-roken$(EXEEXT) > tmp.h ;\
diff --git a/crypto/heimdal/packages/debian/patches/022_openafs b/crypto/heimdal/packages/debian/patches/022_openafs
new file mode 100644
index 0000000..64899fd
--- /dev/null
+++ b/crypto/heimdal/packages/debian/patches/022_openafs
@@ -0,0 +1,15 @@
+Index: heimdal-0.7.2/lib/krb5/keytab_keyfile.c
+===================================================================
+--- heimdal-0.7.2.orig/lib/krb5/keytab_keyfile.c 2005-01-09 09:57:18.000000000 +1100
++++ heimdal-0.7.2/lib/krb5/keytab_keyfile.c 2006-03-09 12:50:07.121398112 +1100
+@@ -48,8 +48,8 @@
+ *
+ */
+
+-#define AFS_SERVERTHISCELL "/usr/afs/etc/ThisCell"
+-#define AFS_SERVERMAGICKRBCONF "/usr/afs/etc/krb.conf"
++#define AFS_SERVERTHISCELL "/etc/openafs/ThisCell"
++#define AFS_SERVERMAGICKRBCONF "/etc/openafs/etc/krb.conf"
+
+ struct akf_data {
+ int num_entries;
diff --git a/crypto/heimdal/packages/debian/patches/025_pthreads b/crypto/heimdal/packages/debian/patches/025_pthreads
new file mode 100644
index 0000000..980a8ad
--- /dev/null
+++ b/crypto/heimdal/packages/debian/patches/025_pthreads
@@ -0,0 +1,13 @@
+Index: heimdal-0.7.2/cf/pthreads.m4
+===================================================================
+--- heimdal-0.7.2.orig/cf/pthreads.m4 2006-03-09 12:55:11.651102560 +1100
++++ heimdal-0.7.2/cf/pthreads.m4 2006-03-09 12:59:12.806441376 +1100
+@@ -32,7 +32,7 @@
+ 2.*)
+ native_pthread_support=yes
+ PTHREADS_CFLAGS=-pthread
+- PTHREADS_LIBS=-pthread
++ PTHREADS_LIBS="-pthread -lpthread"
+ ;;
+ esac
+ ;;
diff --git a/crypto/heimdal/packages/debian/patches/026_posix_max b/crypto/heimdal/packages/debian/patches/026_posix_max
new file mode 100644
index 0000000..bf26032
--- /dev/null
+++ b/crypto/heimdal/packages/debian/patches/026_posix_max
@@ -0,0 +1,293 @@
+Index: heimdal-0.7.2/appl/kf/kf_locl.h
+===================================================================
+--- heimdal-0.7.2.orig/appl/kf/kf_locl.h 2002-09-05 06:29:04.000000000 +1000
++++ heimdal-0.7.2/appl/kf/kf_locl.h 2006-03-09 12:59:30.120809192 +1100
+@@ -79,3 +79,7 @@
+ #define KF_PORT_NAME "kf"
+ #define KF_PORT_NUM 2110
+ #define KF_VERSION_1 "KFWDV0.1"
++
++#ifndef MAXPATHLEN
++#define MAXPATHLEN 4096
++#endif
+Index: heimdal-0.7.2/appl/kf/kfd.c
+===================================================================
+--- heimdal-0.7.2.orig/appl/kf/kfd.c 2005-05-27 23:43:24.000000000 +1000
++++ heimdal-0.7.2/appl/kf/kfd.c 2006-03-09 12:59:30.121809040 +1100
+@@ -128,7 +128,7 @@
+ krb5_ticket *ticket;
+ char *name;
+ char ret_string[10];
+- char hostname[MAXHOSTNAMELEN];
++ char hostname[MaxHostNameLen];
+ krb5_data data;
+ krb5_data remotename;
+ krb5_data tk_file;
+Index: heimdal-0.7.2/appl/kx/kx.h
+===================================================================
+--- heimdal-0.7.2.orig/appl/kx/kx.h 2003-04-17 02:45:43.000000000 +1000
++++ heimdal-0.7.2/appl/kx/kx.h 2006-03-09 12:59:30.122808888 +1100
+@@ -107,6 +107,10 @@
+ #include <sys/stropts.h>
+ #endif
+
++#ifndef MAXPATHLEN
++#define MAXPATHLEN 4096
++#endif
++
+ /* defined by aix's sys/stream.h and again by arpa/nameser.h */
+
+ #undef NOERROR
+Index: heimdal-0.7.2/appl/login/login_access.c
+===================================================================
+--- heimdal-0.7.2.orig/appl/login/login_access.c 2001-06-05 00:09:45.000000000 +1000
++++ heimdal-0.7.2/appl/login/login_access.c 2006-03-09 12:59:30.123808736 +1100
+@@ -163,11 +163,11 @@
+
+ static char *myhostname(void)
+ {
+- static char name[MAXHOSTNAMELEN + 1] = "";
++ static char name[MaxHostNameLen + 1] = "";
+
+ if (name[0] == 0) {
+ gethostname(name, sizeof(name));
+- name[MAXHOSTNAMELEN] = 0;
++ name[MaxHostNameLen] = 0;
+ }
+ return (name);
+ }
+Index: heimdal-0.7.2/appl/login/login_locl.h
+===================================================================
+--- heimdal-0.7.2.orig/appl/login/login_locl.h 2005-04-23 01:38:54.000000000 +1000
++++ heimdal-0.7.2/appl/login/login_locl.h 2006-03-09 12:59:30.124808584 +1100
+@@ -150,6 +150,10 @@
+ #endif
+
+
++#ifndef MAXPATHLEN
++#define MAXPATHLEN 4096
++#endif
++
+ struct spwd;
+
+ extern char **env;
+Index: heimdal-0.7.2/appl/popper/popper.h
+===================================================================
+--- heimdal-0.7.2.orig/appl/popper/popper.h 2004-07-14 19:10:30.000000000 +1000
++++ heimdal-0.7.2/appl/popper/popper.h 2006-03-09 12:59:30.125808432 +1100
+@@ -154,6 +154,10 @@
+ #define POP_MAILDIR "/usr/spool/mail"
+ #endif
+
++#ifndef MAXPATHLEN
++#define MAXPATHLEN 4096
++#endif
++
+ #define POP_DROP POP_MAILDIR "/.%s.pop"
+ /* POP_TMPSIZE needs to be big enough to hold the string
+ * defined by POP_TMPDROP. POP_DROP and POP_TMPDROP
+Index: heimdal-0.7.2/appl/rcp/rcp_locl.h
+===================================================================
+--- heimdal-0.7.2.orig/appl/rcp/rcp_locl.h 2005-05-30 04:24:43.000000000 +1000
++++ heimdal-0.7.2/appl/rcp/rcp_locl.h 2006-03-09 12:59:30.125808432 +1100
+@@ -65,3 +65,7 @@
+ #endif
+ #undef _PATH_RSH
+ #define _PATH_RSH BINDIR "/rsh"
++
++#ifndef MAXPATHLEN
++#define MAXPATHLEN 4096
++#endif
+Index: heimdal-0.7.2/appl/rsh/rsh_locl.h
+===================================================================
+--- heimdal-0.7.2.orig/appl/rsh/rsh_locl.h 2005-12-29 05:00:05.000000000 +1100
++++ heimdal-0.7.2/appl/rsh/rsh_locl.h 2006-03-09 12:59:30.126808280 +1100
+@@ -172,3 +172,7 @@
+ #define do_write(F, B, L, I) write((F), (B), (L))
+ #define do_read(F, B, L, I) read((F), (B), (L))
+ #endif
++
++#ifndef MAXPATHLEN
++#define MAXPATHLEN 4096
++#endif
+Index: heimdal-0.7.2/appl/test/tcp_server.c
+===================================================================
+--- heimdal-0.7.2.orig/appl/test/tcp_server.c 1999-12-16 21:31:08.000000000 +1100
++++ heimdal-0.7.2/appl/test/tcp_server.c 2006-03-09 12:59:30.127808128 +1100
+@@ -44,7 +44,7 @@
+ krb5_principal server;
+ krb5_ticket *ticket;
+ char *name;
+- char hostname[MAXHOSTNAMELEN];
++ char hostname[MaxHostNameLen];
+ krb5_data packet;
+ krb5_data data;
+ u_int32_t len, net_len;
+Index: heimdal-0.7.2/lib/gssapi/gssapi_locl.h
+===================================================================
+--- heimdal-0.7.2.orig/lib/gssapi/gssapi_locl.h 2005-05-31 06:53:46.000000000 +1000
++++ heimdal-0.7.2/lib/gssapi/gssapi_locl.h 2006-03-09 12:59:30.128807976 +1100
+@@ -84,6 +84,10 @@
+ *
+ */
+
++#ifndef MAXPATHLEN
++#define MAXPATHLEN 4096
++#endif
++
+ extern krb5_context gssapi_krb5_context;
+
+ extern krb5_keytab gssapi_krb5_keytab;
+Index: heimdal-0.7.2/lib/gssapi/import_name.c
+===================================================================
+--- heimdal-0.7.2.orig/lib/gssapi/import_name.c 2003-03-17 04:33:31.000000000 +1100
++++ heimdal-0.7.2/lib/gssapi/import_name.c 2006-03-09 12:59:30.129807824 +1100
+@@ -90,7 +90,7 @@
+ char *tmp;
+ char *p;
+ char *host;
+- char local_hostname[MAXHOSTNAMELEN];
++ char local_hostname[MaxHostNameLen];
+
+ *output_name = NULL;
+
+Index: heimdal-0.7.2/lib/kdfs/k5dfspag.c
+===================================================================
+--- heimdal-0.7.2.orig/lib/kdfs/k5dfspag.c 2002-08-13 01:11:58.000000000 +1000
++++ heimdal-0.7.2/lib/kdfs/k5dfspag.c 2006-03-09 12:59:30.130807672 +1100
+@@ -78,6 +78,9 @@
+ #define WAIT_USES_INT
+ typedef krb5_sigtype sigtype;
+
++#ifndef MAXPATHLEN
++#define MAXPATHLEN 4096
++#endif
+
+ /*
+ * Need some syscall numbers based on different systems.
+Index: heimdal-0.7.2/lib/krb5/get_addrs.c
+===================================================================
+--- heimdal-0.7.2.orig/lib/krb5/get_addrs.c 2004-05-26 07:26:05.000000000 +1000
++++ heimdal-0.7.2/lib/krb5/get_addrs.c 2006-03-09 12:59:30.139806304 +1100
+@@ -49,7 +49,7 @@
+ gethostname_fallback (krb5_context context, krb5_addresses *res)
+ {
+ krb5_error_code ret;
+- char hostname[MAXHOSTNAMELEN];
++ char hostname[MaxHostNameLen];
+ struct hostent *hostent;
+
+ if (gethostname (hostname, sizeof(hostname))) {
+Index: heimdal-0.7.2/lib/krb5/get_host_realm.c
+===================================================================
+--- heimdal-0.7.2.orig/lib/krb5/get_host_realm.c 2005-04-20 04:52:51.000000000 +1000
++++ heimdal-0.7.2/lib/krb5/get_host_realm.c 2006-03-09 12:59:30.140806152 +1100
+@@ -95,7 +95,7 @@
+ krb5_realm **realms)
+ {
+ static char *default_labels[] = { "_kerberos", NULL };
+- char dom[MAXHOSTNAMELEN];
++ char dom[MaxHostNameLen];
+ struct dns_reply *r;
+ char **labels;
+ int i, ret;
+@@ -208,7 +208,7 @@
+ const char *host,
+ krb5_realm **realms)
+ {
+- char hostname[MAXHOSTNAMELEN];
++ char hostname[MaxHostNameLen];
+
+ if (host == NULL) {
+ if (gethostname (hostname, sizeof(hostname)))
+Index: heimdal-0.7.2/lib/krb5/krbhst-test.c
+===================================================================
+--- heimdal-0.7.2.orig/lib/krb5/krbhst-test.c 2002-08-23 13:43:18.000000000 +1000
++++ heimdal-0.7.2/lib/krb5/krbhst-test.c 2006-03-09 12:59:30.140806152 +1100
+@@ -87,7 +87,7 @@
+ krb5_init_context (&context);
+ for(i = 0; i < argc; i++) {
+ krb5_krbhst_handle handle;
+- char host[MAXHOSTNAMELEN];
++ char host[MaxHostNameLen];
+
+ for (j = 0; j < sizeof(types)/sizeof(*types); ++j) {
+ printf ("%s for %s:\n", type_str[j], argv[i]);
+Index: heimdal-0.7.2/lib/krb5/krbhst.c
+===================================================================
+--- heimdal-0.7.2.orig/lib/krb5/krbhst.c 2005-05-20 19:09:42.000000000 +1000
++++ heimdal-0.7.2/lib/krb5/krbhst.c 2006-03-09 12:59:30.142805848 +1100
+@@ -763,7 +763,7 @@
+ krb5_error_code ret;
+ int nhost = 0;
+ krb5_krbhst_handle handle;
+- char host[MAXHOSTNAMELEN];
++ char host[MaxHostNameLen];
+ krb5_krbhst_info *hostinfo;
+
+ ret = krb5_krbhst_init(context, realm, type, &handle);
+Index: heimdal-0.7.2/lib/krb5/principal.c
+===================================================================
+--- heimdal-0.7.2.orig/lib/krb5/principal.c 2004-12-29 12:54:54.000000000 +1100
++++ heimdal-0.7.2/lib/krb5/principal.c 2006-03-09 12:59:30.150804632 +1100
+@@ -706,8 +706,8 @@
+ const char *p;
+ krb5_error_code ret;
+ krb5_principal pr;
+- char host[MAXHOSTNAMELEN];
+- char local_hostname[MAXHOSTNAMELEN];
++ char host[MaxHostNameLen];
++ char local_hostname[MaxHostNameLen];
+
+ /* do the following: if the name is found in the
+ `v4_name_convert:host' part, is is assumed to be a `host' type
+@@ -1059,7 +1059,7 @@
+ krb5_principal *ret_princ)
+ {
+ krb5_error_code ret;
+- char localhost[MAXHOSTNAMELEN];
++ char localhost[MaxHostNameLen];
+ char **realms, *host = NULL;
+
+ if(type != KRB5_NT_SRV_HST && type != KRB5_NT_UNKNOWN) {
+Index: heimdal-0.7.2/lib/krb5/verify_init.c
+===================================================================
+--- heimdal-0.7.2.orig/lib/krb5/verify_init.c 2004-05-26 07:45:47.000000000 +1000
++++ heimdal-0.7.2/lib/krb5/verify_init.c 2006-03-09 12:59:30.151804480 +1100
+@@ -90,7 +90,7 @@
+ memset (&entry, 0, sizeof(entry));
+
+ if (ap_req_server == NULL) {
+- char local_hostname[MAXHOSTNAMELEN];
++ char local_hostname[MaxHostNameLen];
+
+ if (gethostname (local_hostname, sizeof(local_hostname)) < 0) {
+ ret = errno;
+Index: heimdal-0.7.2/lib/roken/getaddrinfo_hostspec.c
+===================================================================
+--- heimdal-0.7.2.orig/lib/roken/getaddrinfo_hostspec.c 2005-04-12 21:28:43.000000000 +1000
++++ heimdal-0.7.2/lib/roken/getaddrinfo_hostspec.c 2006-03-09 12:59:30.152804328 +1100
+@@ -48,7 +48,7 @@
+ {
+ const char *p;
+ char portstr[NI_MAXSERV];
+- char host[MAXHOSTNAMELEN];
++ char host[MaxHostNameLen];
+ struct addrinfo hints;
+ int hostspec_len;
+
+Index: heimdal-0.7.2/lib/sl/slc-gram.y
+===================================================================
+--- heimdal-0.7.2.orig/lib/sl/slc-gram.y 2005-04-19 20:28:28.000000000 +1000
++++ heimdal-0.7.2/lib/sl/slc-gram.y 2006-03-09 12:59:30.153804176 +1100
+@@ -46,6 +46,10 @@
+ #include <vers.h>
+ #include <roken.h>
+
++#ifndef PATH_MAX
++#define PATH_MAX 4096
++#endif
++
+ #include "slc.h"
+ extern FILE *yyin;
+ extern struct assignment *a;
OpenPOWER on IntegriCloud