summaryrefslogtreecommitdiffstats
path: root/contrib/perl5/ext/POSIX/Makefile.PL
diff options
context:
space:
mode:
authormarkm <markm@FreeBSD.org>2000-06-25 14:31:11 +0000
committermarkm <markm@FreeBSD.org>2000-06-25 14:31:11 +0000
commitab25befb604b3ae070ab02e122240604d8c70ba7 (patch)
tree380e6432522a50cca1ae03ac84533515a5334749 /contrib/perl5/ext/POSIX/Makefile.PL
parent1aae907d2e4c639383e27084663755749769597a (diff)
downloadFreeBSD-src-ab25befb604b3ae070ab02e122240604d8c70ba7.zip
FreeBSD-src-ab25befb604b3ae070ab02e122240604d8c70ba7.tar.gz
Resolve conflicts.
Diffstat (limited to 'contrib/perl5/ext/POSIX/Makefile.PL')
-rw-r--r--contrib/perl5/ext/POSIX/Makefile.PL13
1 files changed, 12 insertions, 1 deletions
diff --git a/contrib/perl5/ext/POSIX/Makefile.PL b/contrib/perl5/ext/POSIX/Makefile.PL
index d379fdb..c035d75 100644
--- a/contrib/perl5/ext/POSIX/Makefile.PL
+++ b/contrib/perl5/ext/POSIX/Makefile.PL
@@ -1,7 +1,18 @@
+# $FreeBSD$
use ExtUtils::MakeMaker;
+use Config;
+my @libs;
+if ($^O ne 'MSWin32') {
+ if ($Config{archname} =~ /RM\d\d\d-svr4/) {
+ @libs = ('LIBS' => ["-lm -lc -lposix -lcposix"]);
+ }
+ else {
+ @libs = ('LIBS' => ["-lm -lposix -lcposix"]);
+ }
+}
WriteMakefile(
NAME => 'POSIX',
- ($^O eq 'MSWin32' ? () : (LIBS => ["-lm -lposix -lcposix"])),
+ @libs,
MAN3PODS => {}, # Pods will be built by installman.
XSPROTOARG => '-noprototypes', # XXX remove later?
VERSION_FROM => 'POSIX.pm',
OpenPOWER on IntegriCloud