summaryrefslogtreecommitdiffstats
path: root/contrib/openbsm/configure.ac
diff options
context:
space:
mode:
authorrwatson <rwatson@FreeBSD.org>2006-06-27 18:06:41 +0000
committerrwatson <rwatson@FreeBSD.org>2006-06-27 18:06:41 +0000
commit02d6c5b525eb33f2cb80e79944dc5182be119e2c (patch)
treee75771e43b8b10a3afb7a3dbbe6f2bc79e8214a1 /contrib/openbsm/configure.ac
parentf7669e641742373606ef85a4855b7028f5b564a5 (diff)
downloadFreeBSD-src-02d6c5b525eb33f2cb80e79944dc5182be119e2c.zip
FreeBSD-src-02d6c5b525eb33f2cb80e79944dc5182be119e2c.tar.gz
Vendor import of OpenBSM 1.0 alpha 7, with the following change history
notes: - Adopted Solaris-compatible format for subject32_ex and subject64_ex tokens, which previously did not correctly implement variable length address storage. - Prefer inttypes.h to stdint.h; enhance queue.h detection to test for TAILQ_FOREACH_SAFE(), which is present in recent BSD queue.h's, but not older ones. OpenBSM now builds on some FreeBSD 4.x version. - New event types for extended attributes, ACLs, and scheduling. Obtained from: TrustedBSD Project
Diffstat (limited to 'contrib/openbsm/configure.ac')
-rw-r--r--contrib/openbsm/configure.ac20
1 files changed, 10 insertions, 10 deletions
diff --git a/contrib/openbsm/configure.ac b/contrib/openbsm/configure.ac
index 1fca5b7..48dd95e 100644
--- a/contrib/openbsm/configure.ac
+++ b/contrib/openbsm/configure.ac
@@ -2,8 +2,8 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.59)
-AC_INIT([OpenBSM], [1.0a6], [trustedbsd-audit@TrustesdBSD.org],[openbsm])
-AC_REVISION([$P4: //depot/projects/trustedbsd/openbsm/configure.ac#22 $])
+AC_INIT([OpenBSM], [1.0a7], [trustedbsd-audit@TrustesdBSD.org],[openbsm])
+AC_REVISION([$P4: //depot/projects/trustedbsd/openbsm/configure.ac#24 $])
AC_CONFIG_SRCDIR([bin/auditreduce/auditreduce.c])
AC_CONFIG_AUX_DIR(config)
AC_CONFIG_HEADER([config/config.h])
@@ -59,18 +59,18 @@ AC_FUNC_STRFTIME
AC_CHECK_FUNCS([bzero ftruncate gettimeofday inet_ntoa memset strchr strerror strrchr strstr strtol strtoul])
# sys/queue.h exists on most systems, but its capabilities vary a great deal.
-# test for LIST_FIRST, which appears to not exist in all of them, and is
-# necessary for OpenBSM.
+# test for LIST_FIRST and TAILQ_FOREACH_SAFE, which appears to not exist in
+# all of them, and are necessary for OpenBSM.
AC_TRY_LINK([
#include <sys/queue.h>
], [
- struct foo {
- LIST_ENTRY(foo) foo_entries;
- };
- LIST_HEAD(, foo) foo_list;
- struct foo *foo;
- foo = LIST_FIRST(&foo_list);
+ #ifndef LIST_FIRST
+ #error LIST_FIRST missing
+ #endif
+ #ifndef TAILQ_FOREACH_SAFE
+ #error TAILQ_FOREACH_SAFE
+ #endif
], [
AC_DEFINE(HAVE_FULL_QUEUE_H,, Define if queue.h includes LIST_FIRST)
])
OpenPOWER on IntegriCloud