summaryrefslogtreecommitdiffstats
path: root/contrib/ntp/configure.ac
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2016-04-29 08:02:31 +0000
committerdelphij <delphij@FreeBSD.org>2016-04-29 08:02:31 +0000
commit39baf3a8165fd1fa06257b6812862e7113c5b905 (patch)
tree70bef1566f92531ce181ed768429104db003a1fa /contrib/ntp/configure.ac
parentb62280e683e2d7abd347a4549c51e086b1b8911a (diff)
downloadFreeBSD-src-39baf3a8165fd1fa06257b6812862e7113c5b905.zip
FreeBSD-src-39baf3a8165fd1fa06257b6812862e7113c5b905.tar.gz
Fix ntp multiple vulnerabilities.
Approved by: so
Diffstat (limited to 'contrib/ntp/configure.ac')
-rw-r--r--contrib/ntp/configure.ac44
1 files changed, 43 insertions, 1 deletions
diff --git a/contrib/ntp/configure.ac b/contrib/ntp/configure.ac
index 42e18a4..caba8f6 100644
--- a/contrib/ntp/configure.ac
+++ b/contrib/ntp/configure.ac
@@ -302,7 +302,9 @@ AC_CHECK_HEADER(
AC_CHECK_HEADERS([fcntl.h fnmatch.h ieeefp.h inttypes.h kvm.h math.h])
AC_CHECK_HEADERS([memory.h netdb.h poll.h])
-AC_CHECK_HEADERS([sgtty.h stdatomic.h stdlib.h string.h termio.h])
+AC_CHECK_HEADERS([sgtty.h stdatomic.h])
+AC_HEADER_STDBOOL
+AC_CHECK_HEADERS([stdlib.h string.h termio.h])
AC_CHECK_HEADERS([termios.h timepps.h timex.h unistd.h])
case "$host" in
@@ -4158,6 +4160,24 @@ case "$ans" in
esac
+AC_MSG_CHECKING([if we want the explicit 127.0.0.0/8 martian filter])
+AC_ARG_ENABLE(
+ [bug3020-fix],
+ [AS_HELP_STRING(
+ [--enable-bug3020-fix],
+ [+ Provide the explicit 127.0.0.0/8 martian filter]
+ )],
+ [ans=$enableval],
+ [ans=yes]
+)
+AC_MSG_RESULT([$ans])
+case "$ans" in
+ yes)
+ AC_DEFINE([ENABLE_BUG3020_FIX], [1],
+ [Provide the explicit 127.0.0.0/8 martian filter?])
+esac
+
+
AC_MSG_CHECKING([if we should use the IRIG sawtooth filter])
case "$host" in
@@ -4322,6 +4342,28 @@ case "$ntp_ok" in
esac
AC_MSG_RESULT([$ntp_ok])
+###
+
+AC_MSG_CHECKING([if we want dynamic interleave support])
+AC_ARG_ENABLE(
+ [dynamic-interleave],
+ [AS_HELP_STRING(
+ [--enable-dynamic-interleave],
+ [- dynamic interleave support]
+ )],
+ [ntp_ok=$enableval],
+ [ntp_ok=no]
+)
+ntp_dynamic_interleave=0
+case "$ntp_ok" in
+ yes)
+ ntp_dynamic_interleave=1
+ ;;
+esac
+AC_DEFINE_UNQUOTED([DYNAMIC_INTERLEAVE], [$ntp_dynamic_interleave],
+ [support dynamic interleave?])
+AC_MSG_RESULT([$ntp_ok])
+
NTP_UNITYBUILD
dnl gtest is needed for our tests subdirs. It would be nice if we could
OpenPOWER on IntegriCloud