summaryrefslogtreecommitdiffstats
path: root/contrib/libxo/configure.ac
diff options
context:
space:
mode:
authormarcel <marcel@FreeBSD.org>2015-04-27 17:23:19 +0000
committermarcel <marcel@FreeBSD.org>2015-04-27 17:23:19 +0000
commitccd66731b4fbf326f52ead106e5c4b67656100f3 (patch)
tree2743e923a1c968c5a2a8292b75bf32c2e50bfbb3 /contrib/libxo/configure.ac
parente0e7dcf8e606d1a79e3c5327f77915bc557841f3 (diff)
downloadFreeBSD-src-ccd66731b4fbf326f52ead106e5c4b67656100f3.zip
FreeBSD-src-ccd66731b4fbf326f52ead106e5c4b67656100f3.tar.gz
Upgrade libxo to 0.3.2.
Obtained from: https://github.com/Juniper/libxo/tree/0.3.2 Requested by: Phil Shafer <phil@juniper.net> This import incorporates local change 279966. Local change 276260 has been merged-in.
Diffstat (limited to 'contrib/libxo/configure.ac')
-rw-r--r--contrib/libxo/configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/contrib/libxo/configure.ac b/contrib/libxo/configure.ac
index b2553b8..5491d57 100644
--- a/contrib/libxo/configure.ac
+++ b/contrib/libxo/configure.ac
@@ -12,7 +12,7 @@
#
AC_PREREQ(2.2)
-AC_INIT([libxo], [0.2.0], [phil@juniper.net])
+AC_INIT([libxo], [0.3.2], [phil@juniper.net])
AM_INIT_AUTOMAKE([-Wall -Werror foreign -Wno-portability])
# Support silent build rules. Requires at least automake-1.11.
@@ -133,6 +133,14 @@ AC_ARG_ENABLE([debug],
AC_MSG_RESULT([$LIBXO_DEBUG])
AM_CONDITIONAL([LIBXO_DEBUG], [test "$LIBXO_DEBUG" != "no"])
+AC_MSG_CHECKING([whether to build with text-only rendering])
+AC_ARG_ENABLE([text-only],
+ [ --enable-text-only Turn on text-only rendering],
+ [LIBXO_TEXT_ONLY=yes; AC_DEFINE([LIBXO_TEXT_ONLY], [1], [Enable text-only rendering])],
+ [LIBXO_TEXT_ONLY=no])
+AC_MSG_RESULT([$LIBXO_TEXT_ONLY])
+AM_CONDITIONAL([LIBXO_TEXT_ONLY], [test "$LIBXO_TEXT_ONLY" != "no"])
+
AC_CHECK_LIB([m], [lrint])
AM_CONDITIONAL([HAVE_LIBM], [test "$HAVE_LIBM" != "no"])
@@ -233,6 +241,7 @@ AC_CONFIG_FILES([
libxo/xoversion.h
xo/Makefile
xolint/Makefile
+ xohtml/Makefile
packaging/libxo.pc
doc/Makefile
tests/Makefile
@@ -253,6 +262,7 @@ AC_MSG_NOTICE([summary of build options:
bindir: ${XO_BINDIR}
includedir: ${XO_INCLUDEDIR}
share dir: ${XO_SHAREDIR}
+ oxtradoc dir: ${SLAX_OXTRADOCDIR}
compiler: ${CC} (${HAVE_GCC:-no})
compiler flags: ${CFLAGS}
@@ -262,4 +272,5 @@ AC_MSG_NOTICE([summary of build options:
debug: ${LIBXO_DEBUG:-no}
printf-like: ${HAVE_PRINTFLIKE:-no}
libxo-options: ${LIBXO_OPTS:-no}
+ text-only: ${LIBXO_TEXT_ONLY:-no}
])
OpenPOWER on IntegriCloud