summaryrefslogtreecommitdiffstats
path: root/contrib/libstdc++/Makefile.am
diff options
context:
space:
mode:
authorkan <kan@FreeBSD.org>2002-10-10 04:40:44 +0000
committerkan <kan@FreeBSD.org>2002-10-10 04:40:44 +0000
commit05dc917ee76e021c62a5523736d072a864a1e558 (patch)
treea7ab11963cdd5ff6bbcbb9d530cfdd929f370237 /contrib/libstdc++/Makefile.am
parent92318bc515d223b2eeebb665f76e131dd2318b2b (diff)
downloadFreeBSD-src-05dc917ee76e021c62a5523736d072a864a1e558.zip
FreeBSD-src-05dc917ee76e021c62a5523736d072a864a1e558.tar.gz
Gcc 3.2.1-prerelease C++ support bits from the FSF anoncvs repo gcc-3_2-branch on October 9th 2002 20:15 EST.
Diffstat (limited to 'contrib/libstdc++/Makefile.am')
-rw-r--r--contrib/libstdc++/Makefile.am21
1 files changed, 18 insertions, 3 deletions
diff --git a/contrib/libstdc++/Makefile.am b/contrib/libstdc++/Makefile.am
index 98fe098..d412477 100644
--- a/contrib/libstdc++/Makefile.am
+++ b/contrib/libstdc++/Makefile.am
@@ -44,10 +44,25 @@ check-script-install: $(top_builddir)/mkcheck
cd testsuite; \
@glibcpp_builddir@/mkcheck 1)
+# Use 'new-abi-baseline' to create an initial symbol file. Then run
+# 'check-abi' to test for changes against that file.
baseline_file = @baseline_file@
check-abi: $(top_builddir)/testsuite/abi_check
- -(cd testsuite; \
- ./abi_check ${baseline_file})
+ -@(cd testsuite; \
+ ${top_srcdir}/config/abi/extract_symvers \
+ ../src/.libs/libstdc++.so \
+ ./current_symbols.txt; \
+ ./abi_check --check ./current_symbols.txt ${baseline_file})
+
+new-abi-baseline:
+ -@(output=${baseline_file}; \
+ if test -f $${output}; then \
+ output=$${output}.new; \
+ t=`echo $${output} | sed 's=.*config/abi/=='`; \
+ echo "Baseline file already exists, writing to $${t} instead."; \
+ fi; \
+ ${top_srcdir}/config/abi/extract_symvers \
+ src/.libs/libstdc++.so $${output})
# These rules are messy, but are hella worth it.
doxygen:
@@ -93,7 +108,7 @@ distclean-am: distclean-multi
maintainer-clean-am: maintainer-clean-multi
all-multi:
- $(MULTIDO) $(AM_MAKEFLAGS) DO=all multi-do
+ : $(MAKE) ; exec $(MULTIDO) $(AM_MAKEFLAGS) DO=all multi-do
install-multi:
$(MULTIDO) $(AM_MAKEFLAGS) DO=install multi-do
mostlyclean-multi:
OpenPOWER on IntegriCloud