summaryrefslogtreecommitdiffstats
path: root/contrib/libreadline/configure.in
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>1997-06-07 12:17:44 +0000
committerache <ache@FreeBSD.org>1997-06-07 12:17:44 +0000
commitb6bac891b077ba9da2b507a621c4a85d8eb378f1 (patch)
tree273a40857d601fa83d190bfbfb6ae23041a7743d /contrib/libreadline/configure.in
parentc83c156e7342a7eb5f28600f69a0847e24720fc8 (diff)
downloadFreeBSD-src-b6bac891b077ba9da2b507a621c4a85d8eb378f1.zip
FreeBSD-src-b6bac891b077ba9da2b507a621c4a85d8eb378f1.tar.gz
Virgin import of readline-2.1, unneded docs deleted
Diffstat (limited to 'contrib/libreadline/configure.in')
-rw-r--r--contrib/libreadline/configure.in82
1 files changed, 82 insertions, 0 deletions
diff --git a/contrib/libreadline/configure.in b/contrib/libreadline/configure.in
new file mode 100644
index 0000000..13152b8
--- /dev/null
+++ b/contrib/libreadline/configure.in
@@ -0,0 +1,82 @@
+dnl
+dnl Configure script for readline library
+dnl
+dnl report bugs to chet@po.cwru.edu
+dnl
+dnl Process this file with autoconf to produce a configure script.
+AC_REVISION([for Readline 2.1, version 2.04, from autoconf version] AC_ACVERSION)
+LIBVERSION=2.1
+
+AC_INIT(readline.h)
+AC_CONFIG_HEADER(config.h)
+
+dnl make sure we are using a recent autoconf version
+AC_PREREQ(2.10)
+
+AC_CONFIG_AUX_DIR(./support)
+
+AC_CANONICAL_HOST
+
+# We want these before the checks, so the checks can modify their values.
+test -z "$CFLAGS" && CFLAGS=-g auto_cflags=1
+
+AC_PROG_CC
+
+# If we're using gcc and the user hasn't specified CFLAGS, add -O to CFLAGS.
+test -n "$GCC" && test -n "$auto_cflags" && CFLAGS="$CFLAGS -O"
+
+AC_PROG_GCC_TRADITIONAL
+AC_PROG_INSTALL
+AC_PROG_RANLIB
+
+AC_RETSIGTYPE
+
+AC_HEADER_STAT
+AC_HEADER_DIRENT
+
+AC_CHECK_FUNCS(strcasecmp select setenv putenv tcgetattr setlocale lstat)
+
+AC_FUNC_STRCOLL
+
+AC_CHECK_HEADERS(unistd.h stdlib.h varargs.h stdarg.h string.h \
+ sys/ptem.h sys/pte.h sys/stream.h sys/select.h \
+ termcap.h termios.h termio.h sys/file.h locale.h)
+
+BASH_SIGNAL_CHECK
+BASH_REINSTALL_SIGHANDLERS
+
+BASH_FUNC_POSIX_SETJMP
+BASH_FUNC_LSTAT
+BASH_CHECK_GETPW_FUNCS
+BASH_FUNC_STRCOLL
+
+BASH_TYPE_SIGHANDLER
+BASH_HAVE_TIOCGWINSZ
+BASH_HAVE_TIOCSTAT
+BASH_HAVE_FIONREAD
+BASH_MISC_SPEED_T
+BASH_STRUCT_DIRENT_D_INO
+BASH_STRUCT_DIRENT_D_FILENO
+
+case "$host_cpu" in
+*cray*) LOCAL_CFLAGS=-DCRAY ;;
+esac
+
+case "$host_os" in
+isc*) LOCAL_CFLAGS=-Disc386 ;;
+esac
+
+AC_SUBST(CFLAGS)
+AC_SUBST(LOCAL_CFLAGS)
+AC_SUBST(LOCAL_DEFS)
+
+AC_SUBST(host_cpu)
+AC_SUBST(host_os)
+
+AC_SUBST(LIBVERSION)
+
+AC_OUTPUT([Makefile doc/Makefile examples/Makefile],
+[
+# Makefile uses this timestamp file to record whether config.h is up to date.
+echo > stamp-h
+])
OpenPOWER on IntegriCloud