summaryrefslogtreecommitdiffstats
path: root/contrib/libf2c/libI77/configure.in
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2002-05-09 22:47:59 +0000
committerobrien <obrien@FreeBSD.org>2002-05-09 22:47:59 +0000
commitc4cd6f62364376317c26d104dbae2a1d7688c6f1 (patch)
tree67cbb2dcc743690cb31fd56b75a992ce4a6950d9 /contrib/libf2c/libI77/configure.in
parentc95b4b5523419271f1bfef55bc47dfbcdced47c7 (diff)
parenteb81e01d5162436a00b210305c91bbba234a0238 (diff)
downloadFreeBSD-src-c4cd6f62364376317c26d104dbae2a1d7688c6f1.zip
FreeBSD-src-c4cd6f62364376317c26d104dbae2a1d7688c6f1.tar.gz
This commit was generated by cvs2svn to compensate for changes in r96295,
which included commits to RCS files with non-trunk default branches.
Diffstat (limited to 'contrib/libf2c/libI77/configure.in')
-rw-r--r--contrib/libf2c/libI77/configure.in23
1 files changed, 17 insertions, 6 deletions
diff --git a/contrib/libf2c/libI77/configure.in b/contrib/libf2c/libI77/configure.in
index 20f2628..988a8e5 100644
--- a/contrib/libf2c/libI77/configure.in
+++ b/contrib/libf2c/libI77/configure.in
@@ -1,5 +1,5 @@
# Process this file with autoconf to produce a configure script.
-# Copyright (C) 1995, 1997, 1998, 2001 Free Software Foundation, Inc.
+# Copyright (C) 1995, 1997, 1998, 2001, 2002 Free Software Foundation, Inc.
# Contributed by Dave Love (d.love@dl.ac.uk).
#
#This file is part of GNU Fortran.
@@ -23,6 +23,16 @@ AC_PREREQ(2.12.1)
AC_INIT(ftell_.c)
AC_CONFIG_HEADER(config.h)
+# These defines are necessary to get 64-bit file size support.
+
+AC_DEFINE(_XOPEN_SOURCE, 500L, [Get Single Unix Specification semantics])
+# The following is needed by irix6.2 so that struct timeval is declared.
+AC_DEFINE(_XOPEN_SOURCE_EXTENDED, 1, [Get Single Unix Specification semantics])
+# The following is needed by Solaris2.5.1 so that struct timeval is declared.
+AC_DEFINE(__EXTENSIONS__, 1, [Solaris extensions])
+AC_DEFINE(_FILE_OFFSET_BITS, 64, [Get 64-bit file size support])
+AC_DEFINE(_LARGEFILE_SOURCE, 1, [Define for HP-UX ftello and fseeko extension.])
+
dnl Checks for programs.
dnl FIXME AC_PROG_CC wants CC to be able to link things, but it may
@@ -33,6 +43,9 @@ define([AC_PROG_CC_WORKS],[])
# the makefiles
AC_PROG_CC
+LIBTOOL='$(SHELL) ../libtool'
+AC_SUBST(LIBTOOL)
+
test "$AR" || AR=ar
AC_SUBST(AR)
AC_PROG_MAKE_SET
@@ -111,11 +124,6 @@ AC_CACHE_VAL(g77_cv_sys_mingw32,
AC_MSG_RESULT($g77_cv_sys_mingw32)
-AC_CHECK_HEADER(fcntl.h,
- test $g77_cv_header_posix = yes && AC_DEFINE(_POSIX_SOURCE),
- AC_DEFINE(NO_FCNTL, 1, [Define if fcntl.h is missing.])
- AC_DEFINE(OPEN_DECL, 1, [Define if fcntl.h is missing.]))
-
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
AC_TYPE_SIZE_T
@@ -136,9 +144,12 @@ else
AC_MSG_RESULT(no)
fi
+AC_CHECK_FUNCS(fseeko)
+AC_CHECK_FUNCS(ftello)
AC_CHECK_FUNCS(ftruncate)
AC_CHECK_FUNCS(mkstemp)
AC_CHECK_FUNCS(tempnam)
+AC_CHECK_FUNCS(tmpnam)
# posix will guarantee the right behaviour for sprintf, else we can't be
# sure; HEADER_STDC wouldn't be the right check in sunos4, for instance.
OpenPOWER on IntegriCloud