summaryrefslogtreecommitdiffstats
path: root/contrib/cvs/configure.in
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2008-03-19 14:46:59 +0000
committerobrien <obrien@FreeBSD.org>2008-03-19 14:46:59 +0000
commitc54c20f64254351041b8ea9719450e4d774ac0a5 (patch)
tree0ae354b8af76926a31947d53202545980b36afe4 /contrib/cvs/configure.in
parent5f43f46b30a84be45042a4dd83992110d7588aad (diff)
downloadFreeBSD-src-c54c20f64254351041b8ea9719450e4d774ac0a5.zip
FreeBSD-src-c54c20f64254351041b8ea9719450e4d774ac0a5.tar.gz
Import of 1.11 branch snapshot - using the 10-March-2008 code base.
Diffstat (limited to 'contrib/cvs/configure.in')
-rw-r--r--contrib/cvs/configure.in78
1 files changed, 67 insertions, 11 deletions
diff --git a/contrib/cvs/configure.in b/contrib/cvs/configure.in
index b690de2..8c83397 100644
--- a/contrib/cvs/configure.in
+++ b/contrib/cvs/configure.in
@@ -1,9 +1,9 @@
dnl configure.in for cvs
-AC_INIT([Concurrent Versions System (CVS)],[1.11.22],
+AC_INIT([Concurrent Versions System (CVS)],[1.11.22.1],
[bug-cvs@nongnu.org],[cvs])
AC_CONFIG_SRCDIR(src/cvs.h)
AM_INIT_AUTOMAKE([gnu 1.7.9 dist-bzip2 no-define])
-AC_PREREQ(2.58)
+AC_PREREQ(2.60)
AC_PREFIX_PROGRAM(cvs)
AM_CONFIG_HEADER(config.h)
@@ -300,9 +300,6 @@ if test "$ac_cv_func_fnmatch_works" = no; then
AC_LIBSOURCE(fnmatch.h.in)
fi
-dnl for the buffer routine replacements
-AC_FUNC_MMAP
-
# Try to find connect and gethostbyname.
AC_CHECK_LIB(nsl, main)
AC_SEARCH_LIBS(connect, xnet socket inet,
@@ -498,6 +495,53 @@ dnl end --with-editor
dnl
dnl
+dnl begin --with-ssh
+dnl
+
+# What remote shell transport should the :extssh: client cvs default to using?
+AC_ARG_WITH(
+ [ssh],
+ AC_HELP_STRING(
+ [--with-ssh],
+ [The default remote shell CVS will use for :extssh: transport
+ (default autodetects)]), ,
+ [with_ssh="ssh lshc ssh2"])
+
+if test no = "$with_ssh"; then
+ AC_MSG_WARN([Failed to find usable remote shell. Using 'ssh'.])
+ with_ssh=ssh
+elif test yes = "$with_ssh"; then
+ # Make --with-ssh mean the same thing as --with-ssh=ssh
+ with_ssh=ssh
+fi
+
+if echo $with_ssh |grep ^/ >/dev/null; then
+ # If $with_ssh is an absolute path, issue a warning if the executable
+ # doesn't exist or isn't usable, but then trust the user and use it
+ # regardless
+ with_default_ssh=$with_ssh
+ AC_MSG_CHECKING([for a remote shell])
+ if ! test -f $with_ssh \
+ || ! test -x $with_ssh; then
+ # warn the user that they may encounter problems
+ AC_MSG_WARN([$with_ssh is not a path to an executable file])
+ fi
+else
+ # Search for a remote shell
+ AC_CHECK_PROGS([with_default_ssh], [$with_ssh], "ssh")
+fi
+
+AC_DEFINE_UNQUOTED(
+ [SSH_DFLT], ["$with_default_ssh"],
+ [The default remote shell to use, if one does not specify the
+ CVS_SSH environment variable.])
+dnl done with finding a default CVS_SSH value
+dnl
+dnl end --with-ssh
+dnl
+
+
+dnl
dnl begin --with-rsh
dnl
dnl Many sites no longer desire the use of "rsh" as the default
@@ -514,7 +558,7 @@ AC_ARG_WITH(
dnl and `remsh' is the remote shell, but look for it first since it
dnl probably won't exist on any platform where it shouldn't be preferred
dnl to `rsh'.
- [with_rsh="remsh rsh ssh"])
+ [with_rsh="remsh rsh ssh lshc ssh2"])
if test no = "$with_rsh"; then
AC_MSG_WARN([Failed to find usable remote shell. Using 'rsh'.])
@@ -662,6 +706,11 @@ dnl Done setting CVS Administrator Group
dnl
dnl
+dnl end --with-*
+dnl
+
+
+dnl
dnl Set the NDBM library to use.
dnl
dnl XXX - FIXME - FIXME - FIXME - XXX
@@ -699,16 +748,23 @@ dnl Done selecting NDBM library.
dnl
-
dnl
-dnl end --with-*
+dnl begin --enables
dnl
-dnl
-dnl begin --enables
-dnl
+dnl Allow mmap for the buffer routine replacements to be disabled in
+dnl case of problems.
+AC_ARG_ENABLE(
+ [mmap],
+ AC_HELP_STRING(
+ [--disable-mmap],
+ [Don't mmap RCS files]))
+
+if test no != "$enable_mmap"; then
+ AC_FUNC_MMAP
+fi
# Check for options requesting client and server feature. If none are
# given and we have connect(), we want the full client & server arrangement.
OpenPOWER on IntegriCloud