summaryrefslogtreecommitdiffstats
path: root/contrib/com_err/Makefile.am
diff options
context:
space:
mode:
authordfr <dfr@FreeBSD.org>2008-05-08 10:58:50 +0000
committerdfr <dfr@FreeBSD.org>2008-05-08 10:58:50 +0000
commite240fee79046f8dbba1a0ff52d7d6d7db5d9ecf4 (patch)
tree131df5020a56c7084d76394b9548d7dab723aa7b /contrib/com_err/Makefile.am
parent5f37114b4d2f0a697ddf2afbe2a749070a907421 (diff)
parentef0dde97c702ca80dd1f2b3e2fe4274803f68d01 (diff)
downloadFreeBSD-src-e240fee79046f8dbba1a0ff52d7d6d7db5d9ecf4.zip
FreeBSD-src-e240fee79046f8dbba1a0ff52d7d6d7db5d9ecf4.tar.gz
This commit was generated by cvs2svn to compensate for changes in r178843,
which included commits to RCS files with non-trunk default branches.
Diffstat (limited to 'contrib/com_err/Makefile.am')
-rw-r--r--contrib/com_err/Makefile.am25
1 files changed, 20 insertions, 5 deletions
diff --git a/contrib/com_err/Makefile.am b/contrib/com_err/Makefile.am
index ae48cb5..64d4976 100644
--- a/contrib/com_err/Makefile.am
+++ b/contrib/com_err/Makefile.am
@@ -1,24 +1,39 @@
-# $Id: Makefile.am,v 1.27 2002/03/10 23:52:41 assar Exp $
+# $Id: Makefile.am 21619 2007-07-17 07:34:00Z lha $
include $(top_srcdir)/Makefile.am.common
YFLAGS = -d
lib_LTLIBRARIES = libcom_err.la
-libcom_err_la_LDFLAGS = -version-info 2:1:1
+libcom_err_la_LDFLAGS = -version-info 2:3:1
+
+if versionscript
+libcom_err_la_LDFLAGS += $(LDFLAGS_VERSION_SCRIPT)$(srcdir)/version-script.map
+endif
bin_PROGRAMS = compile_et
include_HEADERS = com_err.h com_right.h
-compile_et_SOURCES = compile_et.c compile_et.h parse.y lex.l
+compile_et_SOURCES = compile_et.c compile_et.h parse.y lex.l lex.h
-libcom_err_la_SOURCES = error.c com_err.c roken_rename.h
+libcom_err_la_CPPFLAGS = $(ROKEN_RENAME)
+dist_libcom_err_la_SOURCES = error.c com_err.c roken_rename.h
-CLEANFILES = lex.c parse.c parse.h
+if do_roken_rename
+nodist_libcom_err_la_SOURCES = snprintf.c strlcpy.c
+endif
$(compile_et_OBJECTS): parse.h parse.c ## XXX broken automake 1.4s
compile_et_LDADD = \
+ libcom_err.la \
$(LIB_roken) \
$(LEXLIB)
+
+snprintf.c:
+ $(LN_S) $(srcdir)/../roken/snprintf.c .
+strlcpy.c:
+ $(LN_S) $(srcdir)/../roken/strlcpy.c .
+
+EXTRA_DIST = version-script.map
OpenPOWER on IntegriCloud