summaryrefslogtreecommitdiffstats
path: root/contrib/apr-util/configure.in
diff options
context:
space:
mode:
authorpeter <peter@FreeBSD.org>2013-07-28 06:02:40 +0000
committerpeter <peter@FreeBSD.org>2013-07-28 06:02:40 +0000
commit0aadc82afbae4dbc41da86cd4f9b2ceb8ddcb17d (patch)
tree6a96e078c28ea05d418b4e2722bc03b0b930a78b /contrib/apr-util/configure.in
parent7594fa5c70305cda65deedc5cc7e08dc037727cd (diff)
parentb910f82d487cf989800adbd1a65b3a7f71b46277 (diff)
downloadFreeBSD-src-0aadc82afbae4dbc41da86cd4f9b2ceb8ddcb17d.zip
FreeBSD-src-0aadc82afbae4dbc41da86cd4f9b2ceb8ddcb17d.tar.gz
Update subversion-1.8.0 -> 1.8.1. Update supporting
components: apr-1.4.6 -> 1.4.8 and apr-util-1.4.1 -> 1.5.2. This is a post point-zero bug-fix / fix-sharp-edges release, including some workarounds for UTF-8 for people who haven't yet turned on WITH_ICONV.
Diffstat (limited to 'contrib/apr-util/configure.in')
-rw-r--r--contrib/apr-util/configure.in38
1 files changed, 29 insertions, 9 deletions
diff --git a/contrib/apr-util/configure.in b/contrib/apr-util/configure.in
index 3aff513..3002810 100644
--- a/contrib/apr-util/configure.in
+++ b/contrib/apr-util/configure.in
@@ -42,13 +42,20 @@ AC_CANONICAL_SYSTEM
AC_PROG_INSTALL
-# Use -no-install to link the test programs on all platforms
-# but Darwin, where it would cause the programs to be linked
-# against installed versions of libapr instead of those just
-# built.
+# Use -no-install or -no-fast-install to link the test
+# programs on all platforms but Darwin, where it would cause
+# the programs to be linked against installed versions of
+# libapr instead of those just built.
case $host in
-*-apple-darwin*) LT_NO_INSTALL="" ;;
-*) LT_NO_INSTALL="-no-install" ;;
+ *-apple-darwin*)
+ LT_NO_INSTALL=""
+ ;;
+ *-mingw*)
+ LT_NO_INSTALL="-no-fast-install"
+ ;;
+ *)
+ LT_NO_INSTALL="-no-install"
+ ;;
esac
AC_SUBST(LT_NO_INSTALL)
@@ -151,8 +158,6 @@ dnl Determine what DBM backend type to use.
dnl Find Expat
dnl Find an iconv library
APU_CHECK_CRYPTO
-APU_CHECK_CRYPTO_OPENSSL
-APU_CHECK_CRYPTO_NSS
APU_FIND_LDAP
APU_CHECK_DBM
APU_CHECK_DBD
@@ -224,7 +229,22 @@ dnl copy apr's rules.mk into our build directory.
if test ! -d ./build; then
$mkdir_p build
fi
-cp $APR_BUILD_DIR/apr_rules.mk $abs_builddir/build/rules.mk
+dnl
+dnl MinGW: If APR is shared, APR_DECLARE_EXPORT will be defined in the
+dnl internal CPPFLAGS, but APR-Util needs APU_DECLARE_EXPORT instead.
+dnl If APR is static, APR_DECLARE_STATIC will be defined in the
+dnl internal CPPFLAGS, but APR-Util needs APU_DECLARE_STATIC too.
+dnl
+case $host in
+ *-mingw*)
+ sed -e 's/-DAPR_DECLARE_EXPORT/-DAPU_DECLARE_EXPORT/' \
+ -e 's/-DAPR_DECLARE_STATIC/-DAPU_DECLARE_STATIC -DAPR_DECLARE_STATIC/' \
+ < $APR_BUILD_DIR/apr_rules.mk > $abs_builddir/build/rules.mk
+ ;;
+ *)
+ cp $APR_BUILD_DIR/apr_rules.mk $abs_builddir/build/rules.mk
+ ;;
+esac
dnl
dnl BSD/OS (BSDi) needs to use a different include syntax in the Makefiles
OpenPOWER on IntegriCloud